Return 400 if a workerType is submitted that doesn't have a valid AMI

RESOLVED DUPLICATE of bug 1159637

Status

Taskcluster
AWS-Provisioner
RESOLVED DUPLICATE of bug 1159637
2 years ago
2 years ago

People

(Reporter: selenamarie, Unassigned)

Tracking

Details

Per discussion today about busted AMIs ending up in workerTypes.
Should we also mark a worker type (somehow) as disabled, if the AMI is dropped at a later point in time? If so, we should probably work out how to display it differently in the UI, and also work out how we want to monitor/alert on it.

I'll also raise a separate bug about fixing the script in generic worker to reverse the order of deleting old ami and updating worker type with new ami during worker-type update process...
See Also: → bug 1249581
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1159637
You need to log in before you can comment on or make changes to this bug.