Closed Bug 1249438 Opened 4 years ago Closed 4 years ago

write a test for ServiceWorkerRegistrar::RegisterServiceWorker() that exercises duplicate entries

Categories

(Core :: DOM: Service Workers, defect)

45 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla48
Tracking Status
firefox48 --- fixed

People

(Reporter: bkelly, Assigned: bkelly)

References

Details

(Whiteboard: btpp-active)

Attachments

(3 files)

It seems we don't have one because we didn't catch the regression I introduced in bug 1246319 P1 and then fixed in bug 1246319 comment 31.
Whiteboard: btpp-active
It was a bit more work to write the test than I expected.  I had to first expose the RegisterServiceWorker() logic to the test in P1 and then update gtests from there.

This new test case catches the error introduced in bug 1246319.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=0499fb010513
Attachment #8735583 - Flags: review?(amarchesini)
Attachment #8735580 - Flags: review?(amarchesini) → review+
Attachment #8735581 - Flags: review?(amarchesini) → review+
Attachment #8735583 - Flags: review?(amarchesini) → review+
You need to log in before you can comment on or make changes to this bug.