There's a lot of empty space at the right of Storage Inspector in vertical mode if I select an item

VERIFIED FIXED in Firefox 50

Status

P2
normal
VERIFIED FIXED
3 years ago
2 months ago

People

(Reporter: arni2033, Assigned: miker)

Tracking

Trunk
Firefox 50

Firefox Tracking Flags

(firefox47 affected, firefox50 verified)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
>>>   My Info:   Win7_64, Nightly 47, 32bit, ID 20160218030349
STR:
1. Open https://bugzilla.mozilla.org/
2. Open devtools -> Options, select dark theme, enable Storage, open Storage tab
3. Open "Cookies" folder, select any item.
4. Dock devtools to the right side of window, slowly resize devtools from minimal width to maximal

AR:  There's a lot of empty space at the right of Storage Inspector in vertical mode
ER:  There should be no white empty space in Storage Inspector

Screenshot:
> https://dl.dropboxusercontent.com/s/pgozvyuiiya5b0w/screenshot%201%20-%20There%27s%20a%20lot%20of%20empty%20space%20at%20the%20right%20of%20Storage%20Inspector%20in%20vertical%20mode.png?dl=0
Created attachment 8721279 [details]
storage-space.png

Let's add the screenshot to the bug so that we have a permanent record.
Caused by the sidebar element having max-width: 500px. This is nice when the devtools are docked in the bottom, but when docked to the side, this style shouldn't be there: it forces all UI elements (tree, table, sidebar) to have width 500px and the remaining space is empty.
Created attachment 8766389 [details] [diff] [review]
1249445-fix-sidebar-max-width.diff
Attachment #8766389 - Flags: review?(pbrosset)
Filter under Floccinaucinihilipilification
Assignee: nobody → mratcliffe
Priority: -- → P2
Keywords: checkin-needed

Comment 5

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/fx-team/rev/7575dca97e98
Remove empty space when devtools docked right r=pbro
Keywords: checkin-needed

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/7575dca97e98
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 50

Comment 7

2 years ago
I have successfully reproduce this bug on firefox nightly 47.0a1 (2016-02-18)
with windows 7 (32 bit)
Mozilla/5.0 (Windows NT 6.1; rv:47.0) Gecko/20100101 Firefox/47.0

I found this fix on latest nightly 50.0a1 (2016-07-17)

Mozilla/5.0 (Windows NT 6.1; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID : 20160717030211

[bugday-20160720]

Updated

2 years ago
Status: RESOLVED → VERIFIED
status-firefox50: fixed → verified

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.