TEST-UNEXPECTED-FAIL | test_direct_update.py TestDirectUpdate.test_update | AssertionError: DownloadFailedPanel == DownloadFailedPanel (maxProgress is not equal to expected patch size)

RESOLVED DUPLICATE of bug 1249467

Status

RESOLVED DUPLICATE of bug 1249467
3 years ago
3 years ago

People

(Reporter: maja_zf, Unassigned)

Tracking

({intermittent-failure})

46 Branch
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox47 affected)

Details

(URL)

Traceback (most recent call last):
 09:10:22     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/venv/lib/python2.7/site-packages/marionette/marionette_test.py", line 344, in run
 09:10:22     INFO -     testMethod()
 09:10:22     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/venv/lib/python2.7/site-packages/firefox_ui_tests/update/direct/test_direct_update.py", line 20, in test_update
 09:10:22     INFO -     self.download_and_apply_available_update(force_fallback=False)
 09:10:22     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/venv/lib/python2.7/site-packages/firefox_puppeteer/testcases/update.py", line 301, in download_and_apply_available_update
 09:10:22     INFO -     self.download_update(about_window)
 09:10:22     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/venv/lib/python2.7/site-packages/firefox_puppeteer/testcases/update.py", line 283, in download_update
 09:10:22     INFO -     self.wait_for_download_finished(window, timeout)
 09:10:22     INFO -   File "/Users/mozauto/jenkins/workspace/mozilla-aurora_update/build/venv/lib/python2.7/site-packages/firefox_puppeteer/testcases/update.py", line 402, in wait_for_download_finished
 09:10:22     INFO -     window.deck.download_failed)
 09:10:22     INFO - TEST-INFO took 3936ms
 09:10:22     INFO - Update test results: 
 09:10:22     INFO - [{'build_post': None,
 09:10:22     INFO -   'build_pre': {'buildid': u'20160215004021',
 09:10:22     INFO -                 'channel': u'aurora',
 09:10:22     INFO -                 'disabled_addons': None,
 09:10:22     INFO -                 'locale': u'en-US',
 09:10:22     INFO -                 'mar_channels': set([u'firefox-mozilla-aurora']),
 09:10:22     INFO -                 'url_aus': u'https://aus5.mozilla.org/update/3/Firefox/46.0a2/20160215004021/Darwin_x86_64-gcc3-u-i386-x86_64/en-US/aurora/Darwin%2013.4.0/default/default/update.xml?force=1',
 09:10:22     INFO -                 'user_agent': u'Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:46.0) Gecko/20100101 Firefox/46.0',
 09:10:22     INFO -                 'version': u'46.0a2'},
 09:10:22     INFO -   'fallback': False,
 09:10:22     INFO -   'patch': {'channel': u'aurora', 'download_duration': None},
 09:10:22     INFO -   'success': False}]
(Reporter)

Updated

3 years ago
Version: 47 Branch → 46 Branch
Same issue as bug 1249467. I will dupe and expand the other one to cover both tests.
Summary: TEST-UNEXPECTED-FAIL | test_direct_update.py TestDirectUpdate.test_update | AssertionError: DownloadFailedPanel == DownloadFailedPanel → TEST-UNEXPECTED-FAIL | test_direct_update.py TestDirectUpdate.test_update | AssertionError: DownloadFailedPanel == DownloadFailedPanel (maxProgress is not equal to expected patch size)
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1249467
You need to log in before you can comment on or make changes to this bug.