when using a java applet, any typed keystrokes repeat

RESOLVED DUPLICATE of bug 124774

Status

Core Graveyard
Java APIs for DOM
RESOLVED DUPLICATE of bug 124774
17 years ago
6 years ago

People

(Reporter: 46point2, Assigned: Ashu Kulkarni)

Tracking

Trunk
PowerPC
Mac System 8.6

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.8) Gecko/20020204
BuildID:    20002020405

When attempting to enter text into a Java applet, all keystrokes are doubled --
i.e., typing THERE results in TTHHEERREE.  This is a problem when typing answers
into a crossword.




Reproducible: Always
Steps to Reproduce:
1. Go to the page listed (or any other Java/JavaScript crossword page at
http://www.guardian.co.uk/crossword/).
2. Try to type within the crossword applet.


Actual Results:  Entered letters are doubled, and fill two spaces.  Typing T
once will fill two spaces with Ts.  Hitting delete will erase two letters at a
time.  Cursor keystrokes jump two spaces.

Expected Results:  Display single letters.

The underlying Java VM is MRJ 2.2.5

This occurs both at the Guardian page (which uses a proprietary applet leavened
with JavaScript) and at the Independent crossword page (an example is listed
below*), which simply uses the Crossword Compiler Java applet (from
http://www.x-word.com/).  

Reasonably, it will occur with other Java applets.

* http://enjoyment.independent.co.uk/old/crosswords/cryptic/20020212cryptic.html

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 124774 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Component: Java APIs for DOM → Java APIs for DOM
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.