Blank Hello panel in Firefox Beta 7

RESOLVED WONTFIX

Status

--
blocker
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: bogdan_maris, Assigned: standard8)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox44 unaffected, firefox45blocking verified, firefox46 unaffected, firefox47 unaffected)

Details

Attachments

(2 attachments)

Created attachment 8721199 [details]
Screenshot showing the issue

[Affected versions]:
- Firefox 45 beta 7

[Affected platforms]:
- Mac OS X 10.10.5
- Ubuntu 14.04 64bit
- Windows build has not arrived yet.

[Steps to reproduce]:
1. Start Firefox 45 beta 7
2. Click Hello icon

[Expected result]:
- Hello panel is displayed with content in it

[Actual result]:
- Blank hello panel

[Regression range]:
- This 

[Additional notes]:
- Latest Nightly and Developer Edition not affected.
- Browser console output:
> Loop:TelemetryAddValue failed for histogram 'LOOP_MAU' Exception { message: "Component returned failure code: 0x…", result: 2147942487, name: "NS_ERROR_ILLEGAL_VALUE", filename: "chrome://loop/content/modules/MozLo…", lineNumber: 1044, columnNumber: 0, data: null, stack: "kMessageHandlers.TelemetryAddValue@…", location: XPCWrappedNative_NoHelper } MozLoopAPI.jsm:1046
> 1455868781293	Services.HealthReport.HealthReporter	WARN	Saved state file does not exist.
> The Components object is deprecated. It will soon be removed. utils.js:9:15
> No string found for key:  first_time_experience_subheading panel.js:1119:13
> OpenGL compositor Initialized Succesfully.Version: 2.1 ATI-1.32.25 Vendor: ATI Technologies Inc. Renderer: AMD Radeon HD 6750M OpenGL Engine FBO Texture Target: TEXTURE_2D
> SyntaxError: JSON.parse: expected property name or '}' at line 1 column 3 of the JSON data l10n.js:100:16
I have Hello version 1.1.2 installed.
Guys, this is a serious issue wrt Hello.
tracking-firefox45: --- → blocking
Flags: needinfo?(standard8)
Flags: needinfo?(ianb)
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #0)
> [Regression range]:
> - This 

Forgot to finish my sentence here. 
This is not a regression since Hello was enabled as an add-on in this beta build only.
(Assignee)

Comment 4

3 years ago
This is the result of a bad merge to beta, caused by a few work arounds previously.

I think the fix would be small. I'm seeing what that looks like now.
Flags: needinfo?(standard8)
Flags: needinfo?(ianb)
(Assignee)

Comment 5

3 years ago
Created attachment 8721216 [details] [diff] [review]
Fix the beta

This was caused by a bad set of merges, compounded with a profile that doesn't show the issue - I reproduced this on a fresh profile.

This patch is the difference between aurora & beta. I messed up here, as there were previously some workarounds in place for not having all the L10n code in 45, and I didn't make sure they were all reverted.

I'm going to change our uplift procedures so that either we export the add-on direct into each branch (and create a patch from that), or we do uplift in the normal way, but then do a diff verify with the actual add-on or previous branch to check there's no unexpected differences.
Assignee: nobody → standard8
(Assignee)

Comment 6

3 years ago
Comment on attachment 8721216 [details] [diff] [review]
Fix the beta

Approval Request Comment
[Feature/regressing bug #]: Bad uplifts for Firefox Hello
[User impact if declined]: Users won't be able to access Hello for this beta cycle.
[Describe test coverage new/current, TreeHerder]: These parts have been in m-c & aurora. We obviously don't have actual integration/functional test coverage for this - we'll get a test written for that today.
[Risks and why]: Low, existing code that missed getting updated on beta.
[String/UUID change made/needed]: None
Attachment #8721216 - Flags: review?(mdeboer)
Attachment #8721216 - Flags: approval-mozilla-beta?
Comment on attachment 8721216 [details] [diff] [review]
Fix the beta

Review of attachment 8721216 [details] [diff] [review]:
-----------------------------------------------------------------

Confirmed to be working. r=me.
Attachment #8721216 - Flags: review?(mdeboer) → review+
(Assignee)

Comment 9

3 years ago
(In reply to Mark Banner (:standard8) from comment #8)
> https://treeherder.mozilla.org/#/jobs?repo=try&revision=dc05fba07959

Please ignore this, this try push was for something else entirely and the push hooks did the wrong thing.
Flags: in-testsuite?
Comment on attachment 8721216 [details] [diff] [review]
Fix the beta

we want that for sure!
Attachment #8721216 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
https://hg.mozilla.org/releases/mozilla-beta/rev/b935e0100697
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox45: affected → fixed
Resolution: --- → FIXED
backed out by request from sylvestre in https://treeherder.mozilla.org/#/jobs?repo=mozilla-beta&revision=8bf2c5452d44
Status: RESOLVED → REOPENED
status-firefox45: fixed → affected
Flags: needinfo?(standard8)
Resolution: FIXED → ---
(Assignee)

Comment 13

3 years ago
Since we got backed out, marking as wontfix.

I've filed bug 1250107 to cover the test that was missing that we should have had anyway.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Flags: needinfo?(standard8)
Flags: in-testsuite?
Resolution: --- → WONTFIX
I verified using Firefox 45 beta 8 across platforms (Mac OS X 10.10.5, Windows 7 64-bit and Ubuntu 14.04 32-bit) and can confirm that Hello was backed out to version 0.1, and it works as expected.
status-firefox45: affected → verified
You need to log in before you can comment on or make changes to this bug.