Settings menu will be truncated if set 'loop.fxa.enabled' to false

RESOLVED FIXED

Status

P2
normal
Rank:
28
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: yliu, Assigned: standard8)

Tracking

({regression})

unspecified
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 wontfix, firefox46 fixed, firefox47 fixed)

Details

(Whiteboard: [btpp-fix-later])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

Build ID: 20160215141016


Steps to reproduce:

1. Add 'loop.fxa.enabled' in about:config and set it to false, restart Firefox.
2. Open Hello panel and click 'Settings' button.


Actual results:

Settings button shows on the bottom left and settings menu is truncated.


Expected results:

Settings button shows on the lower right and settings menu displays correctly.
(Reporter)

Comment 1

3 years ago
Created attachment 8721200 [details]
Hello_settings menu.png
(Reporter)

Updated

3 years ago
status-firefox45: --- → affected
status-firefox46: --- → affected
status-firefox47: --- → affected
Depends on: 1236082
Keywords: regression
(Assignee)

Comment 2

3 years ago
We should just remove this pref. Its a hidden pref, and was only intended as safety if we needed to backout parts of a new feature - see bug 1077996 comment 0 - and it was intended to be removed a while ago.

I can't think of a reason to keep it atm.
Rank: 28
Priority: -- → P2
Whiteboard: [btpp-fix-later]
Created attachment 8723988 [details] [review]
[loop] Standard8:bug-1249552-fxa-enabled > mozilla:master
(Assignee)

Comment 4

3 years ago
Comment on attachment 8723988 [details] [review]
[loop] Standard8:bug-1249552-fxa-enabled > mozilla:master

As mentioned earlier, this removes the old preference setting. Its more code that I though we would remove when I first glanced at it, but that's good to clean up.
Attachment #8723988 - Flags: review?(fernando.campo)
(Assignee)

Updated

3 years ago
Assignee: nobody → standard8
Comment on attachment 8723988 [details] [review]
[loop] Standard8:bug-1249552-fxa-enabled > mozilla:master

looks good to me && tested on dev-edition
Attachment #8723988 - Flags: review?(fernando.campo) → review+
(Assignee)

Comment 6

3 years ago
https://github.com/mozilla/loop/commit/848b5245388a17f68bf90e89bb97b8c64c75eaa0
Status: NEW → RESOLVED
Iteration: --- → 47.3 - Mar 7
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Depends on: 1261118
Updating status flags since this was fixed in 47.
status-firefox46: affected → ?
status-firefox47: affected → fixed
(Assignee)

Comment 8

2 years ago
Actually, this was fixed in 46. That was before I was starting to link bugs to releases.
status-firefox45: affected → wontfix
status-firefox46: ? → fixed
You need to log in before you can comment on or make changes to this bug.