Disable accelerated Canvas on OS X versions < 10.8

RESOLVED FIXED in Firefox 45

Status

()

Core
Graphics
--
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mchang, Assigned: mchang)

Tracking

44 Branch
mozilla47
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 wontfix, firefox45 fixed, firefox46 fixed, firefox47 fixed)

Details

(Whiteboard: gfx-noted)

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
From bug 1246633 and https://www.reddit.com/r/firefox/comments/45yhbm/4402_graphics_glitches_and_hanging_after_half_an - it looks like accelerated skia canvas on 10.7 is still bad. Disable it on anything less than 10.8
(Assignee)

Comment 1

2 years ago
Created attachment 8721350 [details] [diff] [review]
Disable accelerated canvas on OS X less than Mountain Lion
Attachment #8721350 - Flags: review?(milan)
Attachment #8721350 - Flags: review?(milan) → review+
(Assignee)

Updated

2 years ago
Blocks: 1246633
Blocks: 1249640
(Assignee)

Comment 4

2 years ago
Reminder to uplift after landing
Flags: needinfo?(mchang)

Comment 5

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/4d3389cf88c5
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
(Assignee)

Comment 6

2 years ago
Comment on attachment 8721350 [details] [diff] [review]
Disable accelerated canvas on OS X less than Mountain Lion

Approval Request Comment
[Feature/regressing bug #]: Accelerated Skia GL on OS X on Mac
[User impact if declined]: Flickering on some users hardware, see bug 1246633.
[Describe test coverage new/current, TreeHerder]: Manual 
[Risks and why]: Low - This disables accelerated Skia on OS X less than 10.8. This was the behavior before Gecko 44.
[String/UUID change made/needed]: None
Attachment #8721350 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1246633
Marking affected for current versions.
status-firefox44: --- → wontfix
status-firefox45: --- → affected
status-firefox46: --- → affected
Comment on attachment 8721350 [details] [diff] [review]
Disable accelerated canvas on OS X less than Mountain Lion

Revert to pre-44 behavior for older versions of OS X. 
Sounds better for users than the reported flickering problems.
Attachment #8721350 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+

Comment 10

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-aurora/rev/83b6cc7ed8e0
status-firefox46: affected → fixed
(Assignee)

Comment 11

2 years ago
Comment on attachment 8721350 [details] [diff] [review]
Disable accelerated canvas on OS X less than Mountain Lion

See comment 6.

Only uplift if bug 1249312 also gets uplifted please.
Flags: needinfo?(mchang)
Attachment #8721350 - Flags: approval-mozilla-beta?
Comment on attachment 8721350 [details] [diff] [review]
Disable accelerated canvas on OS X less than Mountain Lion

Lame cc from bug 1249312

I am very unhappy to see this kind of uplift request that late in the cycle.
Next time, please be on top of your features, Bug 1244569 has been reported a month ago :/
Taking it for the only reason that 45 is an ESR.
Attachment #8721350 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 13

2 years ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/48e0d09b052c
status-firefox45: affected → fixed
You need to log in before you can comment on or make changes to this bug.