Animation should stop while page in background

RESOLVED DUPLICATE of bug 120154

Status

()

Core
ImageLib
--
enhancement
RESOLVED DUPLICATE of bug 120154
17 years ago
16 years ago

People

(Reporter: Gili, Assigned: Stuart Parmenter)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:0.9.8) Gecko/20020204
BuildID:    

Save everyone headache :) stop all sort of (GIF) animation while the page isn't
in the foreground.

Reproducible: Always
Steps to Reproduce:
1. Visit page with animation
2. Move focus to another tab or minimize browser
3. CPU usage remains high (due to animation)

Comment 1

16 years ago
->imagelib
Assignee: trudelle → pavlov
Component: XP Apps → ImageLib
QA Contact: sairuh → tpreston

Comment 2

16 years ago
Since this bug was reported, a newer version of Mozilla (1.0 RC1) has been
released. Reporter, please can you check to see whether this bug is still 
present in a recent build (Moz1-RC1 or a new nightly build). If
this bug does not occur please can you resolve the bugreport?


BTW, Page works fine for me (Moz1.0 RC1 buiild id 2002041903)
(Reporter)

Comment 3

16 years ago
It's too hard to tell with the newer versions; cpu usage is so low normally (3%
or so) that there is no way for me to know if it's still running in the
background. This issue is about a concept: you shouldn't care about animating
images in the background. Isn't there a way to verify whether this is happening
from the design docs or the code?

Comment 4

16 years ago

*** This bug has been marked as a duplicate of 120154 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.