Closed Bug 1249793 Opened 7 years ago Closed 7 years ago

Allow dependency data to be teed out to human-readable log

Categories

(Firefox Build System :: General, defect)

defect
Not set
normal

Tracking

(firefox47 affected)

RESOLVED DUPLICATE of bug 1108293
Tracking Status
firefox47 --- affected

People

(Reporter: bugzilla, Unassigned)

Details

The output that MSVC's -showIncludes option generates can be very useful sometimes for diagnosing problems with includes. I'd like to be able to specify an option to mach build (or something) so that this data could be teed out to a log verbatim.

The .pp files in deps aren't as useful to the human reader because they strip out the indentation which is necessary for figuring out the actual structure of the include tree.
Dupe of bug 1108293? This feels like a feature that we'd add to that...
Works for me, provided of course that this functionality is indeed brought into the scope of that bug :-)
You should dupe this and bring it into the scope of that bug :)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1108293
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.