Weather.com page is rendered devoid of content with geolocation disabled

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Leman Bennett [Omega], Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8721524 [details]
Screen Shot 2016-02-19 at 17.06.23.png

Weather.com will not display properly. Console reports a js error.

Error: [$injector:modulerr] http://errors.angularjs.org/1.3.16/$injector/modulerr?p0=twc&p1=TWC.pco%20is%20undefined%0A%40https%3A%2F%2Fweather.com%2F%3A2917%3A17%0Ae%40https%3A%2F%2Fweather.com%2Fsites%2Facquia-prod%2Ffiles%2Fjs%2Fjs_UvJV3KFdUaGwcIK62-_zrgEZFWGiisMU0coXVfpm2vk.js%3A36%3A313%0Ad%40https%3A%2F%2Fweather.com%2Fsites%2Facquia-prod%2Ffiles%2Fjs%2Fjs_UvJV3KFdUaGwcIK62-_zrgEZFWGiisMU0coXVfpm2vk.js%3A34%3A490%0Ag%2F%3C%40https%3A%2F%2Fweather.com%2Fsites%2Facquia-prod%2Ffiles%2Fjs%2Fjs_UvJV3KFdUaGwcIK62-_zrgEZFWGiisMU0coXVfpm2vk.js%3A35%3A117%0Aq%40https%3A%2F%2Fweather.com%2Fsites%2Facquia-prod%2Ffiles%2Fjs%2Fjs_UvJV3KFdUaGwcIK62-_zrgEZFWGiisMU0coXVfpm2vk.js%3A7%3A320%0Ag%40https%3A%2F%2Fweather.com%2Fsites%2Facquia-prod%2Ffiles%2Fjs%2Fjs_UvJV3KFdUaGwcIK62-_zrgEZFWGiisMU0coXVfpm2vk.js%3A34%3A399%0Abb%40https%3A%2F%2Fweather.com%2Fsites%2Facquia-prod%2Ffiles%2Fjs%2Fjs_UvJV3KFdUaGwcIK62-_zrgEZFWGiisMU0coXVfpm2vk.js%3A38%3A135%0Axc%2Fd%40https%3A%2F%2Fweather.com%2Fsites%2Facquia-prod%2Ffiles%2Fjs%2Fjs_UvJV3KFdUaGwcIK62-_zrgEZFWGiisMU0coXVfpm2vk.js%3A17%3A381%0Axc%40https%3A%2F%2Fweather.com%2Fsites%2Facquia-prod%2Ffiles%2Fjs%2Fjs_UvJV3KFdUaGwcIK62-_zrgEZFWGiisMU0coXVfpm2vk.js%3A18%3A179%0A%40https%3A%2F%2Fweather.com%2F%3A3007%3A15%0AsetTimeout%20handler*%40https%3A%2F%2Fweather.com%2F%3A3006%3A13%0A

Updated

2 years ago

Comment 1

2 years ago
WFM with almost new profile, reproducible with my current profile.

Could you test:
1) in safe mode:
https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

2) with a fresh profile:
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(lh.bennett)
(Reporter)

Comment 2

2 years ago
Odd. A fresh profile worked this time. However, that procedure failed a few days ago. Both showed the same blank page. What a waste.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(lh.bennett)
Resolution: --- → INVALID
(Reporter)

Comment 3

2 years ago
I've found the real culprit. Geolocation blockage. I'll refile the bug.

Comment 4

2 years ago
(In reply to Leman Bennett [Omega] from comment #3)
> I've found the real culprit. Geolocation blockage. I'll refile the bug.

I suspected that because with a new profile I sa the geoloc notification in the location bar. So I disabled geoloc in about:config (geo.enabled=false) and I reloaded the page, no change. Maybe I needed to clear the cache and restart Firefox to test again with this pref disabled.
(Reporter)

Comment 5

2 years ago
(In reply to Loic from comment #4)
> (In reply to Leman Bennett [Omega] from comment #3)
> > I've found the real culprit. Geolocation blockage. I'll refile the bug.
> 
> I suspected that because with a new profile I sa the geoloc notification in
> the location bar. So I disabled geoloc in about:config (geo.enabled=false)
> and I reloaded the page, no change. Maybe I needed to clear the cache and
> restart Firefox to test again with this pref disabled.

Not cache, local storage. Start fresh and without having answered the Geo prompt any time previously, visit the page with Geo disabled and the site script will panic. I have a feeling that it has something to do with Taboola as this is the website associated with the persistent local storage data bomb found when you visit.

So tired of dealing with that dumb website. I'm going to get my weather info from somewhere else.

Updated

2 years ago
Summary: Weather.com page is rendered devoid of content → Weather.com page is rendered devoid of content with geolocation disabled

Updated

2 years ago
Component: JavaScript Engine → Layout
You need to log in before you can comment on or make changes to this bug.