Closed Bug 1249863 Opened 5 years ago Closed 5 years ago

'Bookmark this page' button is not disabled for blank page after it was moved from hamburger menu

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
minor

Tracking

()

VERIFIED WONTFIX

People

(Reporter: euthanasia_waltz, Unassigned)

References

(Blocks 1 open bug)

Details

STR
1. Start Firefox with new profile
2. Open new tab or blank page (ensure Bookmarks tool icon is disabled)
3. Move Bookmarks tool icon to menu (right-click -> Move to Menu)
4. Open hamburger menu and move Bookmarks to toolbar (right-click -> Move to Toolbar)

ER
Bookmarks tool icon is disabled.
AR
Bookmarks tool icon is enabled.
Status: UNCONFIRMED → NEW
Has STR: --- → yes
Component: Bookmarks & History → Toolbars and Customization
Ever confirmed: true
Summary: Bookmarks icon in toolbar is not disabled on blank page when it is moved → 'Bookmark this page' button is not disabled for blank page after it was moved from hamburger menu
Component: Toolbars and Customization → Bookmarks & History
I think this component is more suitable for it, like bug 980130.


Related code:
_onWidgetWasMoved in https://dxr.mozilla.org/mozilla-central/source/browser/base/content/browser-places.js.
Component: Bookmarks & History → Toolbars and Customization
Also happens when started to "Show blank page".
I think this is now wontfix, because we've removed the disabling code. Can you confirm, Marco?
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(mak77)
Resolution: --- → WONTFIX
Correct.
Flags: needinfo?(mak77)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.