Red lines across whole page in PDF with HWA disabled

RESOLVED FIXED in Firefox 46

Status

()

Firefox
PDF Viewer
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Clemens Eisserer, Unassigned)

Tracking

({regression})

25 Branch
Firefox 46
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 affected, firefox46 fixed, firefox47 fixed, firefox48 fixed)

Details

(Whiteboard: [pdfjs-c-integration])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8721626 [details]
screenshot

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160215141016

Steps to reproduce:

1. Open the PDF located at http://www.gleitschirm-magazin.com/pdf/konzeption1.pdf
2. Scroll down to page 5 (last page)


Actual results:

Red lines across the whole page (please see screenshot)


Expected results:

no red lines, rendering should be consistent with evince and acrobat reader

Comment 1

2 years ago
It appears only with HWA disabled.

Comment 2

2 years ago
It regressed:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b48e06621dc9&tochange=dcbbfcdf7bb4

Probably these patches about Skia.
Status: UNCONFIRMED → NEW
Component: Untriaged → PDF Viewer
Ever confirmed: true
Keywords: regression
Version: 45 Branch → 35 Branch

Updated

2 years ago
Summary: Red lines across whole page in PDF → Red lines across whole page in PDF with HWA disabled
Version: 35 Branch → 25 Branch

Comment 3

2 years ago
Created attachment 8721661 [details]
konzeption1.5.pdf

Updated

2 years ago
Flags: needinfo?(gwright)

Updated

2 years ago
Priority: -- → P2
Whiteboard: [pdfjs-c-integration]
Lee, known issue?
Flags: needinfo?(gwright) → needinfo?(lsalzman)

Updated

2 years ago
Blocks: 848491

Comment 5

2 years ago
On Windows 7,
I can still reproduce the problem on Firefox45.0.2.
However, I cannot reproduce on 46.0b10 and later.
I am having trouble reproducing this on my local 45 release setup.

Can you paste or screenshot the info from the "Graphics" section of "about:support"?

Also, does changing the pref "gfx.xrender.enabled" to false make the issue go away?
Flags: needinfo?(lsalzman) → needinfo?(linuxhippy)

Comment 7

2 years ago
I confirm it's fixed in 46+ (on Win 7 with HWA disabled).

Fix range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d8e260e1535f0ff3877b21d6846380dedf449453&tochange=6630a176477ef903dcf3057db755abc43ba5018d

Fixed by 1082598.

Clemens, can you test with FF46 on Linux, please.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox45: --- → affected
status-firefox46: --- → fixed
status-firefox47: --- → fixed
status-firefox48: --- → fixed
Depends on: 1082598
Resolution: --- → FIXED
(Reporter)

Comment 8

2 years ago
Indeed, with FF46 on Linux I can't reproduce the issue anymore :)
Flags: needinfo?(linuxhippy)

Updated

2 years ago
Target Milestone: --- → Firefox 46
You need to log in before you can comment on or make changes to this bug.