Re-opening a saved paintext draft inserts a <div moz-forward-container>, regression from bug 736584

RESOLVED FIXED in Thunderbird 47.0

Status

Thunderbird
Message Compose Window
RESOLVED FIXED
a year ago
11 months ago

People

(Reporter: Jorg K (GMT+2), Assigned: Jorg K (GMT+2))

Tracking

({regression})

Trunk
Thunderbird 47.0
regression

Thunderbird Tracking Flags

(thunderbird45 fixed, thunderbird46 fixed, thunderbird47 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

a year ago
Re-opening a saved paintext draft inserts a <div moz-forward-container>, regression from bug 736584.

Sorry about that. There is an
  if (isForwarded) {
missing in the plaintext processing.

I'll submit a patch in the next few hours.
(Assignee)

Updated

a year ago
Assignee: nobody → mozilla
Blocks: 736584
Status: NEW → ASSIGNED
Keywords: regression
(Assignee)

Comment 1

a year ago
Created attachment 8721697 [details] [diff] [review]
adding the missing if (isForwarded)

So sorry about this omission. I went to a Mozilla policy meeting today and on the subway it occurred to me that in the HTML part there was an "if (isForwarded) {" which was missing from the plaintext part.

So I tried the plaintext, and sure enough, re-opening a saved plaintext draft runs through the same processing in adds the container which we don't want. The user doesn't notice it unless they inspect the DOM, but anyway, it needs to be fixed.

Sadly the patch looks large, but all it is is adding "if (isForwarded) {}" twice and changing the indentation.

BTW: I've seen Mozreview in action and is doesn't flag blocks whose indentation has changed.

Sorry again for the extra hassle.
Attachment #8721697 - Flags: review?(mkmelin+mozilla)

Updated

a year ago
Attachment #8721697 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 2

a year ago
https://hg.mozilla.org/comm-central/rev/55cda620d5fd

Note TB 45 is only affected if bug 736584 is approved for beta as requested.
Status: ASSIGNED → RESOLVED
Last Resolved: a year ago
status-thunderbird45: --- → affected
status-thunderbird46: --- → affected
status-thunderbird47: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 47.0
(Assignee)

Comment 3

a year ago
Comment on attachment 8721697 [details] [diff] [review]
adding the missing if (isForwarded)

[Approval Request Comment]
Regression caused by (bug #): Bug 736584
Risk to taking this patch (and alternatives if risky):
If bug 736584 is accepted into beta, this needs to go too since it represents a two line amendment.
Attachment #8721697 - Flags: approval-comm-beta?
Attachment #8721697 - Flags: approval-comm-aurora+
(Assignee)

Comment 4

a year ago
Aurora (TB 46):
https://hg.mozilla.org/releases/comm-aurora/rev/b72d062cc0ed
status-thunderbird46: affected → fixed
Comment on attachment 8721697 [details] [diff] [review]
adding the missing if (isForwarded)

http://hg.mozilla.org/releases/comm-esr45/rev/4f7be0c8a92b
Attachment #8721697 - Flags: approval-comm-beta? → approval-comm-beta+

Updated

a year ago
status-thunderbird45: affected → fixed
(Assignee)

Updated

11 months ago
Attachment #8721697 - Flags: approval-comm-beta+ → approval-comm-esr45+
You need to log in before you can comment on or make changes to this bug.