Closed Bug 1249987 Opened 6 years ago Closed 6 years ago

Add as Task icon missing from Customize

Categories

(Calendar :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: walts48, Assigned: Paenglab)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160215141016

Steps to reproduce:

Opened the Customize Widget to add an item to the Mail Toolbar



Actual results:

Noticed that the icons for a Separator and Add as Task were missing from Customize



Expected results:

The icons for a Separator and Add as Task should be visible.
I can confirm the missing 'Add as Task' icon. But on my Linux I see a normal separator. On your screenshot where is only a dot visible. How does the separator look applied on the toolbar?

The separator uses from toolkit -moz-appearance: separator and no icon and isn't influenced by mail/calendar code.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(schw01)
The normal separator appears as expected in 45.0b2, with a test profile, on my test user account.

The dot only appears in 45.0b1 Customize, and as applied to the toolbar.

I just update 45.0b1 to b2 on my production account and the separator is normal.
Flags: needinfo?(schw01)
Summary: Separator and Add as Task icons missing from Customize → Add as Task icon missing from Customize
Walt, thank you for the feedback. So it seems the separator is a GTK3 issue.

Because I have a patch for the calendar icon and the separator needs more investigation, I'm using this bug for this ans file a special bug for the separator.
Component: Toolbars and Tabs → General
Product: Thunderbird → Calendar
Version: 45 Branch → unspecified
Attached patch iconFix.patchSplinter Review
This was my fault. I haven't moved the needed rules to Windows theme and had still a @import in Linux theme.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8722045 - Flags: review?(makemyday)
Attachment #8722045 - Flags: approval-calendar-beta?(philipp)
Attachment #8722045 - Flags: approval-calendar-aurora?(philipp)
Blocks: 1250206
Comment on attachment 8722045 [details] [diff] [review]
iconFix.patch

Review of attachment 8722045 [details] [diff] [review]:
-----------------------------------------------------------------

thanks, r=me
Attachment #8722045 - Flags: review?(makemyday) → review+
http://hg.mozilla.org/comm-central/rev/82c7dbd1e48d
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → 4.9
Comment on attachment 8722045 [details] [diff] [review]
iconFix.patch

Review of attachment 8722045 [details] [diff] [review]:
-----------------------------------------------------------------

r=philipp
Attachment #8722045 - Flags: approval-calendar-beta?(philipp)
Attachment #8722045 - Flags: approval-calendar-beta+
Attachment #8722045 - Flags: approval-calendar-aurora?(philipp)
Attachment #8722045 - Flags: approval-calendar-aurora+
Adding checkin-needed for c-a and c-b.
Keywords: checkin-needed
Does that also need to go to esr45? The approval request flag for beta has been set before the latest merge.
Yes, but I'm not sure if 45esr is still built from beta or esr45.
Thunderbird 45 (betas and final) are being built from c-esr45.
Attachment #8722045 - Flags: approval-calendar-release+
Uplifts to beta and esr45:

https://hg.mozilla.org/releases/comm-beta/rev/e17cda64aa226906d01ef229e1a57ad9ae36c661
https://hg.mozilla.org/releases/comm-esr45/rev/92bc4e768449a4ea1d59abc0f0de0920032da2e1

Uplift to aurora is not required as this patch landed already for 4.9 before the last merge.
Keywords: checkin-needed
Target Milestone: 4.9 → 4.7
(In reply to MakeMyDay from comment #12)
> Uplift to aurora is not required as this patch landed already for 4.9 before
> the last merge.
Thanks, here is the link from the merge:
https://hg.mozilla.org/releases/comm-aurora/rev/82c7dbd1e48d
You need to log in before you can comment on or make changes to this bug.