When replying to a sender's email, it defaults to double space instead of single space line spacing

RESOLVED DUPLICATE of bug 1250051

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 1250051
2 years ago
2 years ago

People

(Reporter: Arthur K., Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:45.0) Gecko/20100101 Firefox/45.0 SeaMonkey/2.42
Build ID: 20160208175903

Steps to reproduce:

Updated to TB 45b1 (and now TB45b2). I replied to a sender's email. Wasn't present in 44b1 or earlier betas.


Actual results:

When typing my reply, all carriage returns are double spaced instead of single space.

For example:

Hello,

I am replying to you.

Thanks for writing.

best,

Me


Expected results:

It should single space carriage returns:

For example:

Hello,

I am replying to you.
Thanks for writing.

best,
Me

Comment 1

2 years ago
Yes, since bug 330891 the default composition format is now paragraph format.

If you don't like it, switch off the option:
Tools > Options, Composition, General:
  When using paragraph format, the enter key creates a new paragraph.

In paragraph format you can use <shift><enter> to create a newline. Paragraph mode pretty much behaves like MS Word or OO/Libreoffice Writer now.

In your example above you most likely want this:

Hello,<enter>
I am replying to you.<shift enter>
Thanks for writing.<enter>
best,<shift enter>
Me

producing this:

<p>Hello,</p>
<p>I am replying to you.<br>
Thanks for writing.</p>
<p>best,<br>
Me</p>

Also refer to the release notes:
https://www.mozilla.org/en-US/thunderbird/45.0beta/releasenotes/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID

Comment 2

2 years ago
What bug number requested this change?

Comment 3

2 years ago
It says so in the first line of my reply in comment #1.

Updated

2 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 1250051
You need to log in before you can comment on or make changes to this bug.