Pages randomly displayed too far to the right

RESOLVED WORKSFORME

Status

()

Core
Layout
P5
trivial
RESOLVED WORKSFORME
17 years ago
15 years ago

People

(Reporter: tk, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020204
BuildID:    2002020415

At seemingly random pages and random intervals pages at the above link
are displayed too far to the right. (The area where it should be displayed is
empty and the page is then displayed to the right of this).

A reload causes the page to display correctly, and many consecutive reloads does
not cause the problem to reappear. Clicking on links to different (parts of)
articles does however replicate the problem at random intervals.

Reproducible: Sometimes
Steps to Reproduce:
1. Go to http://pc.ign.com
2. Read through some articles until the problem arises.

Actual Results:  See description.

Expected Results:  Correctly justified the contents of the article.
Layout.  You may need to reload a few times to see this....
Assignee: trudelle → attinasi
Component: XP Apps → Layout
QA Contact: sairuh → petersen

Updated

17 years ago
QA Contact: petersen → moied

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P5

Updated

17 years ago
Target Milestone: --- → Future

Comment 2

16 years ago
*** Bug 145241 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
If there is a bug in the renderer that causes this to happen on a pretty heavily
visited (by most gamers) site, I don't see how this bug can be trivial with
target milestone of Future.  Doesn't AOL plan to use this codebase in their
official browser?  And if the answer is yes, this kind of bug won't be
acceptable to the end users, and I can guarantee that out of the 30+ million of
them, many will visit ign.com.

Maybe from a technical perspective this is a totally trivial bug, but it is a
major bug from a marketing perspective.  Mozilla 1.0 cannot have this kind of
bug if it is to successfuly gain market share.

Personally I don't care too much if this is fixed or not.  But, it's going to be
bad for advocacy, because everyone is going to point to ign.com and say how
badly Mozilla performs.  This will cause most people to not even try Mozilla
based on their preconceptions of how buggy the original Netscape/Mozilla were.

Comment 4

16 years ago
Using DOM Inspector you can notice that the "large" element which destroys
layout of the page is the following:

388: <p><br> <br>
389: 
390: 
391: <!-- end: navigation 2 -->
392: </p>

Line numbers are specific to the current articles I guess, but you can easily
identify it using search pattern "navigation 2".
I wonder why such a simple tag could be that large, but it may well be a case
that DOM Inspector shows it as full width.
(Reporter)

Comment 5

16 years ago
A small update: In Mozilla 1.1 the problem now seems to be gone from ign.com's
pages, but has for some reason started to appear on http://gamespy.com. On
GameSpy however the problem does not seem to occur randomly, rather every time
you load their front page, so this time it's possibly easier to reproduce/fix?

Comment 6

16 years ago
I cannot reproduce this problem on either pc.ign.com or gamespy.com. 
(The pattern mentioned in comment #4 is still present, though with
'<br>&nbsp;<br>'). 

Is anyone still seeing this?

(Using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207
Phoenix/0.5)
(Reporter)

Comment 7

15 years ago
With Mozilla 1.4 I can no longer reproduce this bug while viewing either ign.com
or gamespy.com's pages. I'd suggest this bug is closed if no one else observe
such layout problems any more.
This was probably fixed by the patch for bug 169620 ....
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.