Thunderbird calendar totally erratic on scroll

RESOLVED DUPLICATE of bug 1139302

Status

RESOLVED DUPLICATE of bug 1139302
3 years ago
3 years ago

People

(Reporter: reginaldlather, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

Open full calendar in tab, select multi-week or month tab and then mouse over the actual calendar and use scroll wheel.


Actual results:

totally erratic scroll  - on average the calendar advanced or regressed 3 years when scrolling only one notch on the mouse wheel.


Expected results:

One notch on the mouse wheel should act in the same manner as a click on the arrow buttons located either side of the 'today' button.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
Component: Untriaged → General
Product: Thunderbird → Calendar
Version: 38 Branch → unspecified

Comment 1

3 years ago
Do you have an option named "smooth scrolling" (or something similar) enabled in the settings of your mouse?
Please, see if bug 1139302 is the same issue.
(Reporter)

Comment 2

3 years ago
Yes, it appears to be a very similar issue. Is there a more perminant fix for this issue yet or one in the pipeline?

FYI - The options for auto scrolling and smooth scrolling in the Thunderbird Advanced Options made no difference.

Comment 3

3 years ago
(In reply to reginaldlather from comment #2)
> Is there a more perminant fix
> for this issue yet or one in the pipeline?

No, as far as I know.

> FYI - The options for auto scrolling and smooth scrolling in the Thunderbird
> Advanced Options made no difference.

According to bug 1139302 the "Smooth Scrolling" option is a setting in the mouse's drivers under the OS and not a Thunderbird's option.

Can you confirm that you have a "Smooth Scrolling" option enabled for your mouse, like bug 1139302 ? Please search in the settings of your OS.

I can't reproduce the issue and I don't know how to do it because in the standard drivers for the mouse on Win7 there isn't that particular setting.

Lightning's code related to the issue should be this (for the month view):
http://mxr.mozilla.org/comm-central/source/calendar/base/content/calendar-month-view.xml#1112
and the only thing I can image is that with that option enabled a lot of events of type "wheel" occur with only one notch on the mouse wheel. Anyway it needs to reproduce the bug to investigate.
reginaldlather, could you provide the information requested by Decathlon in Comment 3?
Flags: needinfo?(reginaldlather)
(Reporter)

Comment 5

3 years ago
I did reply earlier(Feb 23). I do have smooth scrolling and when disabled, as per Decathlon's bug link ( bug 1139302) the issue was resolved. However, the question remains - Is there a perminent fix for this issue? - Decathlons replied .. No, as far as I know.
Flags: needinfo?(reginaldlather)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1139302
You need to log in before you can comment on or make changes to this bug.