"InstallDirectoryPath" parameter does not work in the configuration ini file for the installer command line

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: magicp.jp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

Steps to reproduce:

1. Create configuration ini file (e.g. setup.ini)
------------------
[Install]
InstallDirectoryName=Firefox Beta
InstallDirectoryPath=D:\Program Files\
------------------
2. Download latest Firefox Beta (e.g. FirefoxSetup45b.exe)
3. Run installer in the command line (e.g. <path>\FirefoxSetup45b.exe /INI=<path>\setup.ini)

Please refer to "https://wiki.mozilla.org/Installer:Command_Line_Arguments"



Actual results:

Firefox Beta is installed to "C:\Program Files(x86)\" directory.


Expected results:

Firefox Beta is installed to "InstallDirectoryPath" directory.
(Reporter)

Updated

3 years ago
Has STR: --- → yes
Component: Untriaged → Installer
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
This is the intended behavior. As the wiki page states, if InstallDirectoryName is present, then it will always be used and InstallDirectoryPath will be ignored; the two are mutually exclusive. And the correct behavior of InstallDirectoryName is to use the appropriate system Program Files directory and create a directory with the given name inside there.

Instead of including both options, try using only InstallDirectoryPath, but with the complete path that you want to install to, such as:

[Install]
InstallDirectoryPath=D:\Program Files\Firefox Beta\
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

3 years ago
(In reply to Matt Howell [:mhowell] from comment #1)
> [Install]
> InstallDirectoryPath=D:\Program Files\Firefox Beta\

It works! Thank you.
You need to log in before you can comment on or make changes to this bug.