Closed Bug 1250434 Opened 4 years ago Closed 4 years ago

"Performance" and "Shader Editor" are cut off in toolbar

Categories

(DevTools :: General, defect)

defect
Not set

Tracking

(firefox47 verified)

VERIFIED FIXED
Firefox 47
Tracking Status
firefox47 --- verified

People

(Reporter: elbart, Assigned: bgrins)

References

Details

Attachments

(2 files)

Attached image devtools_cut_off.png
The captions of the buttons are cut off, regardless of how many buttons are enabled.
We shrunk the max-width on the tabs in Bug 1245947, so that's most likely causing this
Blocks: 1245947
Elbart, what OS / version are you using?
Flags: needinfo?(elbart)
Win 7, Nightly 20160223
Flags: needinfo?(elbart)
.devtools-tab {
  max-width: 100px;
}

No cut-off with max-width changed to 100px from 95px.
Mozscreenshots try push: https://treeherder.mozilla.org/#/jobs?repo=try&revision=6992a6f801c1
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Attachment #8722715 - Flags: ui-review?(hholmes)
(In reply to (Unavailable until 3-7) Brian Grinstead [:bgrins] from comment #5)
> Can confirm on perf tool here (but not style editor for some reason):
Sorry, it's "Shader Editor".
Summary: "Performance" and "Style Editor" are cut off in toolbar → "Performance" and "Shader Editor" are cut off in toolbar
Attachment #8722715 - Flags: ui-review?(hholmes) → ui-review+
Comment on attachment 8722715 [details]
MozReview Request: Bug 1250434 - Bump up devtools tab width a bit to fix text overflow on Win7;r=gl

https://reviewboard.mozilla.org/r/36187/#review32893
Attachment #8722715 - Flags: review?(gl) → review+
https://hg.mozilla.org/mozilla-central/rev/e73efeaf2ec8
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Reproduced this bug according to 47.0a1 (2016-2-23) 

Verified is done by Latest Nightly
Build ID 	20160302030209
User Agent 	Mozilla/5.0 (Windows NT 6.3; rv:47.0) Gecko/20100101 Firefox/47.0
 
Tested OS-Windows8.1 32bit
QA Whiteboard: [bugday-20160302]
Successfully reproduced this bug in 47.0a1 (2016-2-23) on Linux 3.13.0-37-generic x86-64 

Found this bug in Latest Beta 47.0b2

Build ID 	20160502152141 
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0 

[bugday-20160504]
As this bug is verified on both windows (comment 13) and Linux (Comment 14), I am marking this as verified!
Status: RESOLVED → VERIFIED
QA Whiteboard: [bugday-20160302] → [bugday-20160302][bugday-20160525]
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.