Closed Bug 1250453 Opened 6 years ago Closed 6 years ago

Consider removing DOMApplicationRegistry::_isLaunchable and DOMApplicationRegistry::allAppsLaunchable (in Webapps.jsm)

Categories

(Core Graveyard :: DOM: Apps, defect)

defect
Not set
normal

Tracking

(firefox47 affected, firefox48 fixed)

RESOLVED FIXED
mozilla48
Tracking Status
firefox47 --- affected
firefox48 --- fixed

People

(Reporter: marco, Assigned: marco)

References

Details

Attachments

(4 files)

It shouldn't be needed anymore after the removal of the desktop web runtime. Now apps are always launchable.
Summary: Consider removing DOMApplicationRegistry::_isLaunchable (in Webapps.jsm) → Consider removing DOMApplicationRegistry::_isLaunchable and DOMApplicationRegistry::allAppsLaunchable (in Webapps.jsm)
Blocks: 1250460
I'll try to do this once bug 1238079 lands.
Assignee: nobody → mcastelluccio
Status: NEW → ASSIGNED
Attachment #8728467 - Flags: review?(myk)
Attachment #8728467 - Flags: review?(myk) → review+
Duplicate of this bug: 1250460
backed out for test failures like https://treeherder.mozilla.org/logviewer.html#?job_id=23450647&repo=mozilla-inbound - seems this test failures are also in the try run
Flags: needinfo?(mcastelluccio)
In the try run, I thought it was unrelated because there's a similar intermittent failure.

Anyway, the test was failing in SimpleTest.showReport, because there was no body element. I'm not sure how the changes from my other patches would affect it.
Flags: needinfo?(mcastelluccio)
Attachment #8729054 - Flags: review?(myk)
The intermittent failure (bug 1251710) is probably the same failure caused by these patches.
These patches probably only changed the timing and so made the test fail consistently instead of intermittently.
Comment on attachment 8729054 [details] [diff] [review]
add_body_spellchecktest

Ouch, what a footgun!  Can you file a bug to make mochitest-chrome (or at least SimpleTest.showReport) fail clearly when a test document hasn't declared an XHTML body element?
Attachment #8729054 - Flags: review?(myk) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/61492626c26afd375cfd7982e7fb751fa45a5f45
Bug 1250453 - Remove DOMApplicationRegistry._isLaunchable property. r=myk

https://hg.mozilla.org/integration/mozilla-inbound/rev/f8c0b81cce33c310c142e125a3680471a6e13b7a
Bug 1250453 - Remove getNotInstalled test. r=myk

https://hg.mozilla.org/integration/mozilla-inbound/rev/5b9c66a957c23df049aa85a7a5a048f6c00973c7
Bug 1250453 - Remove DOMApplicationRegistry.allAppsLaunchable property and related testing API. r=myk

https://hg.mozilla.org/integration/mozilla-inbound/rev/81fb57cf94867467c22d525fb66c3cd3b60b4ba3
Bug 1250453 - Add a body element to test_add_remove_dictionaries.xul to display the test results. r=myk
(In reply to Myk Melez [:myk] [@mykmelez] from comment #13)
> Comment on attachment 8729054 [details] [diff] [review]
> add_body_spellchecktest
> 
> Ouch, what a footgun!  Can you file a bug to make mochitest-chrome (or at
> least SimpleTest.showReport) fail clearly when a test document hasn't
> declared an XHTML body element?

Filed bug 1256351.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.