Closed Bug 1250488 Opened 7 years ago Closed 6 years ago

Modify FTU experience on Hello add-on v1.0

Categories

(Hello (Loop) :: Client, defect, P1)

defect

Tracking

(firefox45 verified)

VERIFIED FIXED
Iteration:
47.3 - Mar 7
Tracking Status
firefox45 --- verified

People

(Reporter: RT, Assigned: dmosedale)

References

Details

User Story

Since FF45 will ship with v1.0 of the add-on we need to adjust the FTU to inform users as well as possible what Hello is about now (sharing websites).

In order to do that, this bug (that is intended to be uplifted to Beta 45 prior to 45 getting on release) requires:
- Resetting the V1.0 preference to ensure everyone sees the FTU panel (previous or existing users)
- Fix panel height bug (currently the v1.0 FTU panel is too high)
- Change the content of the first door hanger to fit the new user journey description (content to be confirmed)
- Change the content of the web page that shows the FTU (https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/hello/start/) to match the new FTU implemented on v1.1 with the slideshow and drop the panel at the end of the slishow (on the last slide)

Attachments

(3 files)

Since FF45 will ship with v1.0 of the add-on we need to adjust the FTU to inform users as well as possible what Hello is about now (sharing websites).

In order to do that, this bug (that is intended to be uplifted to Beta 45 prior to 45 getting on release) requires:
- Resetting the V1.0 preference to ensure everyone sees the FTU panel (previous or existing users)
- Fix panel height bug (currently the v1.0 FTU panel is too high)
- Change the content of the first door hanger to fit the new user journey description (content to be confirmed)
- Change the content of the web page that shows the FTU (https://www.mozilla.org/%LOCALE%/firefox/%VERSION%/hello/start/) to match the new FTU implemented on v1.1 with the slidesshow
Rank: 5
Priority: -- → P1
User Story: (updated)
Note: we just need a beta specific patch for this.
Rank: 5 → 1
Assignee: nobody → dmose
See Also: → 1250607
Depends on: 1250607
I've attached two screenshots showing the panel fix.  The preference change will cause people to be shown the tour again.  Updated content for that comes from the web and will land separately.
Attachment #8722768 - Flags: ui-review?(sfranks)
Attachment #8722768 - Flags: ui-review?(sfranks) → ui-review+
Comment on attachment 8722663 [details] [diff] [review]
Fix Hello UITour window size + show <=45 users FTU again

Looks good. r=Standard8
Attachment #8722663 - Flags: review+
Comment on attachment 8722663 [details] [diff] [review]
Fix Hello UITour window size + show <=45 users FTU again

Approval Request Comment
[Feature/regressing bug #]: Firefox Hello
[User impact if declined]: Users won't get a tour of the changes that have happened since 45.
[Describe test coverage new/current, TreeHerder]: This is an older version of the FTU tour that we previously used and had turned off, the code has unit tests. I've also manually tested the try push on all three platforms.
[Risks and why]: Low, simple change to re-enable previous code and correct the height of the panel
[String/UUID change made/needed]: None
Attachment #8722663 - Flags: approval-mozilla-beta?
Comment on attachment 8722663 [details] [diff] [review]
Fix Hello UITour window size + show <=45 users FTU again

We need that for 45, taking it.
should be in 45 beta 10
Attachment #8722663 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Landed direct on beta, as its only landing there:

https://hg.mozilla.org/releases/mozilla-beta/rev/7f1106d85767
Status: NEW → RESOLVED
Iteration: --- → 47.3 - Mar 7
Closed: 6 years ago
Resolution: --- → FIXED
Flags: qe-verify+
QA Contact: bogdan.maris
Verified using Firefox 45 beta 10 across platforms (Windows 7 64-bit, Mac OS X 10.11 and Ubuntu 14.04 32-bit) that the FTU is properly displayed and hitting 'Getting started' will open a new tab where the tour page will load. 

A note here is that we still encountered bug 1110700, and the same behaviour with high contrast theme or when installing a normal theme (in case of the themes, after a restart the panel will show content)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.