[RR]{ib}Wrong typeface and size, incorrect text flow

VERIFIED DUPLICATE of bug 129350

Status

()

Core
Layout
P1
normal
VERIFIED DUPLICATE of bug 129350
17 years ago
16 years ago

People

(Reporter: Sean Harding, Assigned: Marc Attinasi)

Tracking

({top100})

Trunk
Future
top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Articles on Wired news (http://www.wired.com) are displaying strangely. The
first paragraph is in larger type than the rest of the article, is a serif font
while the rest of the article is sans-serif and is flowing incorrectly so that
text overlaps with the ad on the side. If there are links in the first
paragraph, the non-link text flows over the link text. 

These pages render correctly (the first paragraph is the same typeface and size
as the rest of the paragraphs and it flows properly) in Navigator 4.78 and I

Examples:

http://www.wired.com/news/business/0,1367,50361,00.html (note link in first
paragraph)
http://www.wired.com/news/politics/0,1283,50373,00.html


This is Linux build 2002021208. Hopefully I got the component right...
(Reporter)

Comment 1

17 years ago
Created attachment 69064 [details]
Screenshot of the problem

Here's a screenshot of what the first example looks like in my browser. Notice
that in the first line of the third paragraph, there's a link under the normal
text. Also notice that the right end of the lines is under the ad.
(Reporter)

Comment 2

17 years ago
To clarify, I said "first paragraph," but it's not necessarily the first
paragraph. It's what Wired is calling the first paragraph/section in the article
-- the part that comes before the "See also" links. This may, in fact, be more
than one paragraph of text.
This doesn't seem all that weird, since the first three paragraphs are in a
completely separate part of the document from the rest of the article.  The text
overlapping is definitely a bug, though.  It would be good to have a reduced
testcase for both problems.  Are they related?

Anyway, ->Layout, although some of it could be a residual style issue (Parser).
Assignee: dbaron → attinasi
Component: Style System → Layout
QA Contact: ian → petersen
(Reporter)

Comment 4

17 years ago
They are a different part of the document, but they are not supposed to use a
different font. Take a look at the page in another browser and you'll see what I
mean. 

And, in fact, if I copy and paste the source for those three paragraphs directly
from their page into its own page, it renders fine. See
http://www.seanh.net/fonttest.html

Updated

17 years ago
QA Contact: petersen → moied

Comment 5

17 years ago
Created attachment 69813 [details]
testcase

font properties are reset by <link> at the bottom.  the same <link> tag at the
top does not cause a problem.

Comment 6

17 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8+) Gecko/20020214
I see this with the URL and the testcase.  The first paragraph is size 2 and the
second one is size 4.  Both are reset to 3, but the lines are positioned as
though they are size 3.  The second cell exists for the sole purpose of seeing
where the right margin should be.  The bug occurs without the second cell, but
does not occur if the text is not in a table.

I took out the <a> link.  It's position was not being reset with the rest of the
text.

the href for the <link> tag is invalid, but the bug occurs with both valid and
invalid hrefs.
*** Bug 125651 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2

Comment 8

17 years ago
*** Bug 126738 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Target Milestone: --- → mozilla1.0.1
(Assignee)

Comment 9

17 years ago
Moving Mozilla 1.01 bugs to 'future' milestone with priority P1

I will be pulling bugs from 'future' milestones when scheduling later work.
Priority: P2 → P1
Target Milestone: mozilla1.0.1 → Future
Keywords: top100
I also see this problem, on the original url, and the testcase, and also on 

http://news.bbc.co.uk

I first noticed this on the change from 0.9.7 to 0.9.8, and it still breaks with
0.9.9.
*** Bug 132623 has been marked as a duplicate of this bug. ***
*** Bug 125200 has been marked as a duplicate of this bug. ***
*** Bug 130709 has been marked as a duplicate of this bug. ***
This is the bug with ReResolveStyleContext and blocks within inlines.
Summary: Wrong typeface and size, incorrect text flow → [RR]{in}Wrong typeface and size, incorrect text flow
Summary: [RR]{in}Wrong typeface and size, incorrect text flow → [RR]{ib}Wrong typeface and size, incorrect text flow
This is also causing bbc.co.uk to be broken...

Computed style for the <p> elements inside the <font> tags shows a font size of
"16px" (my default) if the <link> is in and "13px" or "20px" (the sizes
specified in <font>) if I take the <link> out.

It sounds like the presense of the <link> element, even one with a bogus href,
causes residual style to be blown away?

Oh, and another interesting thing...  If the <link> is _valid_ then the sheet is
loaded.  Now say that sheet contains "body { color: red }".  Then the computed
color on the body is red, but the computed color on all children of the body is
my default color from prefs.  So we're not re-resolving style correctly in that
case either..

Updated

17 years ago
No longer blocks: 116273

Updated

17 years ago
Blocks: 116273

Comment 16

17 years ago
suggest OS -> all

(I see the serif font problem on the test case on Windows 2000 and dependent bug
116273 has observations on Win2k, XP, Solaris).

Note that dependent bug has 14 votes, the problem this bug addresses affects two
high-profiles sites (wired and BBC), is a regression and should maybe be pulled
in to 1.0 if at all possible. 
OS: Linux → All
Hardware: PC → All
*** Bug 133048 has been marked as a duplicate of this bug. ***
Both the BBC and the Wired sites are fixed by the patch on bug 129350.

*** This bug has been marked as a duplicate of 129350 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

17 years ago
No longer blocks: 116273

Comment 19

17 years ago
Testcase and URL's renders properly with build ID 20020404, marking verified dup
of Bug 133048 
Status: RESOLVED → VERIFIED
*** Bug 137025 has been marked as a duplicate of this bug. ***

Comment 21

16 years ago
*** Bug 152262 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.