Closed Bug 1250662 Opened 6 years ago Closed 3 years ago

Urlbar highlights scheme instead of domain name if there's whitespace at the beginning

Categories

(Firefox :: Address Bar, defect, P5)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox47 --- affected

People

(Reporter: arni2033, Unassigned)

References

Details

>>>   My Info:   Win7_64, Nightly 47, 32bit, ID 20160222030212
STR:
1. Copy string  "   https://example.org"  in clipboard
2. Press Ctrl+T to open new tab
3. Paste the string copied in Step 1 in urlbar (Ctrl+V)
4.A) Click in searchbar
4.B) Click on the free place on page
4.C) Press Enter, then Escape to cancel loading (try this scenario with "   https://examexample.org")

AR:
 "https:" in urlbar is black, "//example.org" is gray

ER:  Either X or Y
 X) "https://example.org" should be black  (like it was before bug 666717)
 Y) "https://" in urlbar should be gray, "example.org" should be black

Notes:
1) This also happens with "http://" scheme.
2) I'm marking this as regression for now, because (X) was quite OK. Feel free to edit.

This is breakage from bug 666717 (2011-06-23). Pushlog:
> http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=48e72227c2fa&tochange=e0b805cab438
Blocks: 1247816
Sorry, ID in comment 0 is incorrect. this was FIXED (X is fulfilled) in bug 1199601 (2016-02-16)

This bug may be left opened if there's a plan to implement Y (parity-Chrome). As far as I understand, it only requires adding \s* in the beginning of regular expression "matchedURL" in file
/browser/base/content/test/general/browser_urlHighlight.js
Keywords: regression
I can't actually reproduce this, but assuming it is still reproducible calling it a P5.
Priority: -- → P5

I can't reproduce, as well.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.