Intermittent jit test or jsreftest No tests run or test summary not found

RESOLVED FIXED in Firefox 68

Status

()

defect
P3
normal
RESOLVED FIXED
3 years ago
Last month

People

(Reporter: KWierso, Assigned: gbrown)

Tracking

(Regression, {intermittent-failure})

47 Branch
mozilla68
Points:
---

Firefox Tracking Flags

(firefox47 wontfix, firefox48 wontfix, firefox49 wontfix, firefox50 wontfix, firefox68 fixed)

Details

(Whiteboard: [fennec-scouting][stockwell disable-recommended])

Attachments

(1 attachment)

I've been seeing failures like these off and on for a couple of weeks.
https://treeherder.mozilla.org/logviewer.html#?job_id=22192198&repo=mozilla-inbound
Summary: Intermittent jit test No tests run or test summary not found → Intermittent jit test or jsreftest No tests run or test summary not found
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Whiteboard: [fennec-scouting]

Hi Steven, can someone be assigned to this bug and investigate?

This started to perma fail: https://treeherder.mozilla.org/#/jobs?repo=autoland&resultStatus=success%2Cpending%2Crunning%2Ctestfailed%2Cbusted%2Cexception&tier=2&searchStr=jit&revision=3fe91f0bfbffb18239163dd183eb99b63d350798

Log link: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=242508055&repo=autoland&lineNumber=1841

Log snippet:

5:40:44 INFO - Using env: (same as previous command)
05:40:44 INFO - Usage: jit_test.py [options] JS_SHELL [TESTS]
05:40:44 INFO - jit_test.py: error: shell is not executable: /builds/task_1556170763/workspace/build/tests/bin/js
05:40:44 ERROR - Return code: 2
05:40:44 ERROR - No tests run or test summary not found
05:40:44 INFO - TinderboxPrint: jittest-chunked<br/><em class="testfail">T-FAIL</em>
05:40:44 INFO - ##### jittest-chunked log ends
05:40:44 WARNING - # TBPL WARNING #
05:40:44 WARNING - setting return code to 1
05:40:44 WARNING - The jittest-chunked suite: jittest-chunked ran with return status: WARNING
05:40:44 INFO - Running post-action listener: _package_coverage_data
05:40:44 INFO - Running post-action listener: _resource_record_post_action
05:40:44 INFO - Running post-action listener: process_java_coverage_data
05:40:44 INFO - Running post-action listener: stop_device
05:40:48 INFO - Killing logcat pid 458.
05:40:48 INFO - [mozharness: 2019-04-25 05:40:48.254134Z] Finished run-tests step (success)
05:40:48 INFO - Running post-run listener: _resource_record_post_run
05:40:48 INFO - Total resource usage - Wall time: 29s; CPU: 4.0%; Read bytes: 17895424; Write bytes: 134393856; Read time: 1520; Write time: 113724
05:40:48 INFO - TinderboxPrint: CPU usage<br/>3.9%
05:40:48 INFO - TinderboxPrint: I/O read bytes / time<br/>17,895,424 / 1,520
05:40:48 INFO - TinderboxPrint: I/O write bytes / time<br/>134,393,856 / 113,724
05:40:48 INFO - TinderboxPrint: CPU idle<br/>100.3 (87.3%)
05:40:48 INFO - TinderboxPrint: CPU iowait<br/>10.1 (8.8%)
05:40:48 INFO - TinderboxPrint: CPU system<br/>2.2 (1.9%)
05:40:48 INFO - TinderboxPrint: CPU user<br/>2.2 (1.9%)
05:40:48 INFO - TinderboxPrint: Swap in / out<br/>0 / 0
05:40:48 INFO - verify-device - Wall time: 6s; CPU: 7.0%; Read bytes: 6291456; Write bytes: 6209536; Read time: 0; Write time: 8544
05:40:48 INFO - install - Wall time: 18s; CPU: 3.0%; Read bytes: 11071488; Write bytes: 110661632; Read time: 616; Write time: 56148
05:40:48 INFO - run-tests - Wall time: 2s; CPU: Can't collect data; Read bytes: 0; Write bytes: 0; Read time: 0; Write time: 0
05:40:48 WARNING - returning nonzero exit status 1
cleanup

Flags: needinfo?(sdetar)
Assignee: nobody → gbrown
Flags: needinfo?(sdetar)
Regressed by: 1492695

It turns out there are several places where the change to suite 'jittest-chunked'
causes problem. I am abandoning that approach.
Desktop uses this trick, and this returns android '-chunked' handling to a state
similar to what it was before I started messing around!

Pushed by gbrown@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9879ab660a34
Update android mozharness 'chunked' handling, for jittest; r=bc
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.