Closed Bug 1250739 Opened 4 years ago Closed 4 years ago

Intermittent test_user_agent_updates.html | Header UA not overridden

Categories

(Core :: Networking, defect, P3)

47 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
e10s + ---
firefox47 --- wontfix
firefox48 --- wontfix
firefox49 --- fixed
firefox50 --- fixed

People

(Reporter: KWierso, Assigned: valentin)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure, Whiteboard: [necko-active][rr-chaos])

Attachments

(2 files)

Whiteboard: [necko-backlog]
I have this in a recording if somebody wants it.

Note to self: rr@minbar ~/.local/share/rr/firefox-2
Flags: needinfo?(mcmanus)
Whiteboard: [necko-backlog] → [necko-backlog][rr-chaos]
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #3)
> I have this in a recording if somebody wants it.
> 
> Note to self: rr@minbar ~/.local/share/rr/firefox-2

sure - I'll take that trace directory if you still have it.
Flags: needinfo?(mcmanus)
test_user_agent_updates.html is disabled in e10s. We should either fix it or declare it as not an e10s release blocker.
Blocks: e10s-tests
tracking-e10s: --- → +
(In reply to Patrick McManus [:mcmanus] from comment #5)
> (In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #3)
> > I have this in a recording if somebody wants it.
> > 
> > Note to self: rr@minbar ~/.local/share/rr/firefox-2
> 
> sure - I'll take that trace directory if you still have it.

fwiw - this data wasn't recoverable.
Whiteboard: [necko-backlog][rr-chaos] → [necko-active][rr-chaos]
jason - can you find an owner?
Assignee: nobody → jduell.mcbugs
Assignee: jduell.mcbugs → valentin.gosu
I fixed the test for e10s in bug 1250739. Removing tracking flag.
Will use this bug only for to fix intermittent failures.
tracking-e10s: + → ---
I increased the timeout by 500 ms - which should fix the orange. If this _ever_ occurs after landing the patch, I guess I'll need to rewrite the patch.
Attachment #8751232 - Flags: review?(mcmanus)
Attachment #8751232 - Flags: review?(mcmanus) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/baceba6c0eba2b08971995029dfef316b17e957a
Bug 1250739 - Increase test_user_agent_updates.html timeout to be larger than update interval r=mcmanus
https://hg.mozilla.org/mozilla-central/rev/baceba6c0eba
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla49
Duplicate of this bug: 1272381
Not, I fear, actually entirely fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment on attachment 8767660 [details]
Bug 1250739 - test_user_agent_updates.html should use notification instead of flaky setTimeout

https://reviewboard.mozilla.org/r/62100/#review59172
Attachment #8767660 - Flags: review?(hurley) → review+
tracking-e10s: --- → +
Priority: -- → P3
Pushed by valentin.gosu@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/52414dd80d70
test_user_agent_updates.html should use notification instead of flaky setTimeout r=nwgh
https://hg.mozilla.org/mozilla-central/rev/52414dd80d70
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: mozilla49 → mozilla50
You need to log in before you can comment on or make changes to this bug.