API doesn't support status of unlisted add-ons

RESOLVED INVALID

Status

addons.mozilla.org Graveyard
Administration
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: Marc, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.39 Safari/537.36

Steps to reproduce:

I made an API call to check the status of my unlisted add-on.


Actual results:

The API returned: {"error": "No uploaded file for that addon and version."}

But there's indeed an add-on there, I uploaded it, it got signed and I can download the signed one.


Expected results:

I should get a valid API response with all full status and a download URL.
If you're referring to the public add-ons API, unlisted add-ons are intentionally not included. Unlisted add-ons are supposed to be private, so we don't disclose any information about them.
(Reporter)

Comment 2

2 years ago
Oh.  Perhaps I misunderstood the use cases.

I'm trying to automate our internal builds (i.e. dev, QA & staging).  I _assumed_ that I'd create unlisted add-ons for these builds and using the API, simply upload our builds to that.  Then I could get the signed extensions via the status call.

Or are unlisted add-ons simply automatically signed and made available in the upload response?
You should be able to check the status of your upload regardless of listed/unlisted status. Did you upload the file through the API or through the site?
(Reporter)

Comment 4

2 years ago
The upload was through the site, I have no yet tried an upload via the API.

I can check other -- public -- add-ons via the API, and they return valid responses.
Is this the first version you've uploaded for this add-on? I think there's a bug where the first version isn't returned by the API.
(Reporter)

Comment 6

2 years ago
Yes, it's the first version.  I will check with a followup version later this evening.
The first upload status check issue is tracked on GitHub [1]. I think this should work for subsequent uploads. I'm going to close this bug but if it isn't fixed for the next version please file an issue against mozilla/addons-server [2].


[1] https://github.com/mozilla/addons-server/issues/1133
[2] https://github.com/mozilla/addons-server/issues/new?labels[]=signing&labels[]=API&labels[]=bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Resolving as INVALID since I can't set it as a duplicate against GitHub.
Resolution: FIXED → INVALID
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.