5 most recently added bookmarks are not available in the Menu bar - Bookmarks on Mac OS X

VERIFIED FIXED in Firefox 47

Status

()

defect
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: mboldan, Assigned: dao)

Tracking

47 Branch
Firefox 47
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 unaffected, firefox45 unaffected, firefox46 unaffected, firefox47 verified, firefox48 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
[Affected versions]:
- Firefox 47.0a1 (2016-02-23)

[Affected platforms]:
- Mac OS X 10.9.5, Mac OS X 10.11

[Steps to reproduce]:
1. Launch Firefox.
2. Bookmark a few pages.
3. Go to Menu Bar -> Bookmarks and observe the Recently Bookmarked section.

[Expected result]:
- The last 5 bookmarked pages are displayed in the Recently Bookmarked section.

[Actual result]:
- Nothing is displayed in the Recently Bookmarked section.

[Regression range]:
- I will verify if this is a regression ASAP.

[Additional notes]:
- This issue is not reproducible on Windows or on Ubuntu platforms.
(Assignee)

Comment 1

3 years ago
Is this with a new profile? If this is indeed plain broken, I'm a little surprised that nobody else had reported this yet.
(Reporter)

Comment 2

3 years ago
The tests were performed with a clean profile. Only the Recently Bookmark title is displayed in the '5 most recently added bookmarks' section.
(Reporter)

Comment 3

3 years ago
This is not a regression since the issue is reproducible on Firefox 47.0a1 (2016-02-14), build where 'Recently Bookmarked' section was implemented.
(Assignee)

Comment 4

3 years ago
Marco, any idea what's going on here? We're adding the menuitems in the popupshowing event handler. AFAIK this should just work™ on OS X.
Flags: needinfo?(mak77)
(Assignee)

Comment 5

3 years ago
Oh wait, we're actually adding the menuitems asynchronously using asyncExecuteLegacyQueries. I guess this ends up being too late. I thought the native menubar would support live updates, but maybe not. How do we usually deal with this in places menus?
no the native menubar only updates content in onpopupshowing, unfortunately.
We deal with it by populating before it shows... That doesn't work very well with async stuff, indeed we still have an open bug (that atm I cannot find) to add live update support to the native menus...
Flags: needinfo?(mak77)
I think we only update the menu contents here
http://mxr.mozilla.org/mozilla-central/source/widget/cocoa/nsMenuX.mm#581
and when there is new content, we set a flag that tell to rebuild the menu at the next opening.
(Assignee)

Comment 8

3 years ago
(In reply to Marco Bonardo [::mak] from comment #6)
> no the native menubar only updates content in onpopupshowing, unfortunately.
> We deal with it by populating before it shows...

How exactly? Should I use something other than asyncExecuteLegacyQueries or listen to some other popup event?
Flags: needinfo?(mak77)
The queries populating the menubar ATM are synchronous (just PlacesUtils.history.executeQuery), that is not very nice for jank, but probably the only solution for the native menubar, unless someone fixes live updating.
Flags: needinfo?(mak77)
(Assignee)

Comment 10

3 years ago
Posted patch patchSplinter Review
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #8725620 - Flags: review?(mak77)
Comment on attachment 8725620 [details] [diff] [review]
patch

Review of attachment 8725620 [details] [diff] [review]:
-----------------------------------------------------------------

I didn't check on Mac, but it should work off-hand.
Attachment #8725620 - Flags: review?(mak77) → review+

Comment 13

3 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/f7149b0bcf74
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
(Assignee)

Updated

3 years ago
Flags: qe-verify+

Updated

3 years ago
Depends on: 1253930
(Reporter)

Comment 14

3 years ago
The 5 most recently added bookmarks are correctly displayed on Firefox 47.0a1 (2016-03-07)and on Firefox 48.0a1 (2016-03-08).
The tests were performed on Mac OS X 10.9.5 and on Mac OS x 10.11.1.
I am marking this issue Verified-Fixed.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.