Extension inline options do not display

RESOLVED FIXED in Firefox 46

Status

()

defect
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: pwd.mozilla, Assigned: mfinkle)

Tracking

({regression})

Trunk
Firefox 47
All
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox44 unaffected, firefox45 unaffected, firefox46+ fixed, firefox47+ fixed, fennec46+)

Details

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (Android 6.0; Mobile; rv:47.0) Gecko/47.0 Firefox/47.0
Build ID: 20160224030246

Steps to reproduce:

The section within which online options should display simply displays the word "options".
Severity: normal → major
OS: Unspecified → Android
Hardware: Unspecified → All
Hi,i would like to work on this.Could you provide more details on the issue?I'm unable to understand.
Thanks
Flags: needinfo?(pwd.mozilla)
Assuming you have ABP installed:

STR:
Open Fennec
Open overflow menu
Open tools
Open add-ons
Open ABP

Expected Behaviour:
In-line add-on options are displayed e.g. "Disable everywhere, Filter subscriptions, etc"

Actual Results
The word OPTIONS is written in bold with nothing displayed below.

Notes:
This works as expected in release, but the bug exists on Nightly. I'm unsure about beta or aurora.
Flags: needinfo?(pwd.mozilla)
Severity: major → normal
tracking-fennec: --- → ?
Keywords: regression
[Tracking Requested - why for this release]: regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Inline options do not display → Extension inline options do not display
We should be able to write a simple mochitest for this. I have an add-on that creates the different types of options we support:
https://github.com/leibovic/options-kitchen-sink/

See also bug 1079466, where I want us to get rid of this options.xul support.
Looks like we need to add the setting.xml file back, maybe the css too.
Flags: needinfo?(mark.finkle)
Dave - I had to add setting.xml back in since we use that binding. The binding uses a DTD file, so I also added it back.

Tested with Pocket Hits and the options now show up.
Assignee: nobody → mark.finkle
Attachment #8726076 - Flags: review?(dtownsend)
Attachment #8726076 - Flags: review?(dtownsend) → review+
tracking-fennec: ? → 46+
Comment on attachment 8726076 [details] [diff] [review]
fix-addon-options v0.1

Approval Request Comment
[Feature/regressing bug #]: A patch on Fx46
[User impact if declined]: No options in Add-on Manager for add-ons
[Describe test coverage new/current, TreeHerder]:
[Risks and why]: Low. Added back 2 excluded files.
[String/UUID change made/needed]: None
Attachment #8726076 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/0353c350097e
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Regression from 46, tracking
Comment on attachment 8726076 [details] [diff] [review]
fix-addon-options v0.1

We want the addon manager ui to work. Please uplift!
Let's verify this in beta 1.
Attachment #8726076 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.