Video recorded by MediaRecorder API is corrupt and cannot be played

RESOLVED DUPLICATE of bug 1213775

Status

()

Core
Audio/Video: Recording
RESOLVED DUPLICATE of bug 1213775
2 years ago
2 years ago

People

(Reporter: adifran, Unassigned)

Tracking

45 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

141.52 KB, video/webm
Details
(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160215141016

Steps to reproduce:

1. Go to simpl.info/mediarecorder with any Firefox version 45, 46, 47 with Windows 10 x64
2. Record a video
3. Play it back


Actual results:

Once you play it back you will see your recorded video for a couple of seconds and then the "Video is corrupt" message will appear.


Expected results:

The video should have played smoothly.

Updated

2 years ago
Component: Untriaged → Audio/Video: Recording
Product: Firefox → Core

Comment 1

2 years ago
Created attachment 8723150 [details]
test.webm

Indeed, playing the video back doesn't work, the user needs to reload it.

Comment 2

2 years ago
(recorded with FF47)
This should now work with the latest Fx47 and Nightly (Fx48).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1213775

Comment 4

2 years ago
Yes, it's fixed in 48, I tested.
Cool, thanks for re-testing.
You need to log in before you can comment on or make changes to this bug.