Window's controls (Close, Minimixe, Change Size) blink when I scroll page with OMTC disabled

VERIFIED WONTFIX

Status

()

Core
Widget: Win32
VERIFIED WONTFIX
2 years ago
2 years ago

People

(Reporter: arni2033, Unassigned)

Tracking

({regression})

Trunk
x86_64
Windows 7
regression
Points:
---

Firefox Tracking Flags

(firefox47 affected)

Details

(URL)

(Reporter)

Description

2 years ago
>>>   My Info:   Win7_64, Nightly 47, 32bit, ID 20160222030212
Actually, I usually use Release version, because Beta, Aurora and Nightly are completely broken.

STR:
0. Make sure you're testing OS with normal DPI (100%). Otherwise set layout.css.devPixelsPerPx -> 1.0
1. Set layers.offmainthreadcomposition.enabled -> false to avoid all OMTC regressions, disable e10s.
2. Open the following "data:" url or click URL in the form above
>   data:text/html,<title>Scroll page</title><body onload="var str=''; for (i=1;i<=1000;i++)str+='L '+i+'<br>'; document.body.innerHTML=str;">
3. Press End to scroll page to the end
4. Press PageUp several times to scroll page to the top several times

AR:  Each time I press PageUp, window's controls blink.
ER:  Window's controls shouldn't blink

Regression between 2015-01-22 and 2015-01-23 (regressionwindow-wanted). Regression range:
> https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=34e2d2bd7ec4&tochange=a6bbabebed2f

Updated

2 years ago
Component: Untriaged → Widget: Win32
Keywords: regressionwindow-wanted
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
We don't support the non-OMTC configurations at this point, too many things stop working without it.  Arni2033, could you tell me about some of current the OMTC-specific bugs you mention?
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

2 years ago
Why you want those bugs? It made sense to urgently fix them before pushing OMTC to Release, not now...

I reported 5 bugs with "OMTC" in summary (and several bugs about OMTC-related work I don't recall)
5 of them were present as of 2016-02-24. 3 of them are still actual.
> Bug 1212409,  bug 1220371,  bug 1189438 (actual),  bug 1202714 (stolen, fixed),  bug 1251014 (this)

Generally, I expect any graphic bug (including ~5 bugs I haven't reported yet) to be caused by OMTC, because I don't remember that many graphic bugs before that terrible OMTC was introduced.
Unfortunately, without the pref it's now impossible to check if bug is OMTC-specific.
Status: RESOLVED → VERIFIED
See Also: → bug 1059804
You need to log in before you can comment on or make changes to this bug.