Closed Bug 1251036 Opened 4 years ago Closed 4 years ago

./mach command with parameters fails

Categories

(Testing :: Firefox UI Tests, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1245468

People

(Reporter: sydpolk, Unassigned)

Details

./mach firefox-ui-test --gecko-log=blah testing/firefox-ui/tests/firefox_ui_tests/functional/locationbar/test_escape_autocomplete.py
usage: mach [-h] [-v] [--emulator {x86,arm}]
            [--emulator-binary EMULATOR_BINARY] [--emulator-img EMULATOR_IMG]
            [--emulator-res EMULATOR_RES] [--sdcard SDCARD] [--no-window]
            [--logcat-dir LOGDIR] [--logcat-stdout] [--address ADDRESS]
            [--device DEVICE_SERIAL] [--adb-host ADB_HOST]
            [--adb-port ADB_PORT] [--type TYPE] [--homedir HOMEDIR]
            [--app APP] [--app-arg APP_ARGS] [--binary BINARY]
            [--profile PROFILE] [--pref PREFS_ARGS]
            [--preferences PREFS_FILES] [--addon ADDON] [--repeat REPEAT]
            [--testvars TESTVARS] [--tree TREE] [--symbols-path SYMBOLS_PATH]
            [--timeout TIMEOUT] [--startup-timeout STARTUP_TIMEOUT]
            [--shuffle] [--shuffle-seed SHUFFLE_SEED]
            [--total-chunks TOTAL_CHUNKS] [--this-chunk THIS_CHUNK]
            [--sources SOURCES] [--server-root SERVER_ROOT]
            [--gecko-log GECKO_LOG] [--logger-name LOGGER_NAME] [--jsdebugger]
            [--pydebugger PYDEBUGGER] [--socket-timeout SOCKET_TIMEOUT]
            [--e10s] [--tag TEST_TAGS] [--workspace WORKSPACE]
            [--log-unittest LOG_UNITTEST] [--log-raw LOG_RAW]
            [--log-html LOG_HTML] [--log-tbpl LOG_TBPL]
            [--log-xunit LOG_XUNIT] [--log-mach LOG_MACH]
            [--log-mach-buffer LOG_MACH_BUFFER]
            [--log-tbpl-buffer LOG_TBPL_BUFFER] [--log-mach-verbose]
            [--log-mach-level LOG_MACH_LEVEL] [--log-raw-level LOG_RAW_LEVEL]
            [--log-tbpl-level LOG_TBPL_LEVEL]
            [tests [tests ...]]
mach: error: unrecognized arguments: testing/firefox-ui/tests/firefox_ui_tests/functional/locationbar/test_escape_autocomplete.py
Syd-Polks-Mozilla-MBP:mozilla-central spolk$ 

This is similar to bug 1250641.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1245468
You need to log in before you can comment on or make changes to this bug.