need to update the stored mImageWidth/Height on ImageDocuments when we get the document load event

RESOLVED FIXED in Firefox 48

Status

()

Core
Layout: Images
RESOLVED FIXED
2 years ago
a year ago

People

(Reporter: tnikkel, Assigned: tnikkel)

Tracking

unspecified
mozilla48
Points:
---

Firefox Tracking Flags

(firefox48 fixed, firefox-esr45 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
Problem discovered in bug 1145903.
(Assignee)

Comment 1

2 years ago
Created attachment 8723319 [details] [diff] [review]
patch
Attachment #8723319 - Flags: review?(bzbarsky)
(Assignee)

Comment 2

2 years ago
UpdateSizeFromLayout flushes, and then accesses member variables of this, so I guess we have a guarantee that the document stays alive somewhere? If not we need to add some safety here.
Comment on attachment 8723319 [details] [diff] [review]
patch

The only current caller of UpdateSizeFromLayout is HandleEvent, and event handling obviously holds strong refs to the node listeners will run on (because otherwise, other listeners firing before this one can kill the object).  So the existing use is ok; this new use will need to take a strong ref to this....

r=me with that.
Attachment #8723319 - Flags: review?(bzbarsky) → review+
(Assignee)

Comment 4

2 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=78a079aa6708

Comment 5

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/b15d2346d864

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/b15d2346d864
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox48: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla48
Duplicate of this bug: 1145903
Bug 1145903 hits esr45 on a regular basis still. Is this something that'd be safe to uplift there?
Flags: needinfo?(tnikkel)
(Assignee)

Comment 9

a year ago
Comment on attachment 8723319 [details] [diff] [review]
patch

[Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
User impact if declined: sherriffs asked for this to fix an intermittent
Fix Landed on Version: 48
Risk to taking this patch (and alternatives if risky): should be safe
String or UUID changes made by this patch: none

See https://wiki.mozilla.org/Release_Management/ESR_Landing_Process for more info.
Flags: needinfo?(tnikkel)
Attachment #8723319 - Flags: approval-mozilla-esr45?
Comment on attachment 8723319 [details] [diff] [review]
patch

Fix an intermittent, taking it to improve the life of sheriffs
Attachment #8723319 - Flags: approval-mozilla-esr45? → approval-mozilla-esr45+
status-firefox-esr45: --- → affected
Should be in 45.4

Comment 12

a year ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-esr45/rev/5ffa912ed83e
status-firefox-esr45: affected → fixed
You need to log in before you can comment on or make changes to this bug.