Closed Bug 12512 Opened 20 years ago Closed 20 years ago

dozen dummy windows in task switcher

Categories

(Core :: XUL, defect, P3)

x86
Windows NT
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: waterson, Assigned: danm.moz)

References

Details

There seem to be anywhere between three and a dozen "dummy windows" in the
Windows NT task switcher (ALT+TAB) when apprunner is running. Dan, I'm giving
this to you because of something that Hyatt muttered. Please pass along if
you're the wrong guy.

To reproduce:

1. Start apprunner
2. Press ALT+TAB. You'll see several apprunner-ish icons instead of the
(expected) one.
Looks like hiddenwindow.xul is showing up as a task (which is wrong) and (in
addition) it's being launched over and over and over.
*** Bug 12531 has been marked as a duplicate of this bug. ***
*** Bug 12553 has been marked as a duplicate of this bug. ***
*** Bug 12555 has been marked as a duplicate of this bug. ***
Adding nbaca to Cc: list.
Status: NEW → ASSIGNED
Target Milestone: M10
I see something similar on my NT box when running Exceed and displaying my Linux
apprunner to my NT system.  I get about 20 empty windows that do nothing but
take up space on my taskbar (can't open them, rt click doesn't do anything to
them), and the last one is the actual apprunner window.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
They were menupopup frames, which are popup windows, which the Windows OS seems to add
to its window list if they're owned by an invisible window.
I finally got around to testing this via exceed and the multiple exceed windows
have gone away, so it looks like this was the same problem.  Thanks.
QA Contact: ckritzer → waterson
Assigning to originator per new organizational structure.
QA Contact: waterson → ckritzer
Changing QA Contact back to ckritzer@netscape.com
BULK MOVE: Changing component from XUL to XP Toolkit/Widgets: XUL.  XUL 
component will be deleted.
Component: XUL → XP Toolkit/Widgets: XUL
Massive QA Contact update.
QA Contact: ckritzer → jrgm
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.