Closed Bug 1251242 Opened 5 years ago Closed 5 years ago

Some images not visible when Firefox set to using custom colors

Categories

(Firefox :: Untriaged, defect)

44 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1244166

People

(Reporter: sveterv, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160209233610

Steps to reproduce:

1. Create clean Firefox profile
2. Go to this link http://www.phoronix.com/scan.php?page=article&item=2016-feb-6way&num=3
3. You will see some tables/statistics in the article
4. Go to Firefox Preferences->Content->Colors and pick a white color for text, black color for background + set "Always" from "Override the colors..."
5. Go again to the link from 2.


Actual results:

Tables/statistics are not visible.


Expected results:

Tables/statistics should be visible with my custom colors (white text on black background) if they are HTML or with original colors (black text on white/blue background) if they are JPEG's.

I'm not a programmer or graphics designer, so I can't help too much. This problem affects me for years, for example Firefox 10 (yes 10) does have this problem too, probably earlier and newer versions until now too.

Look at those tables they do have three colors originally black/blue text, white/blue background, when you set your custom colors as in 4th step all this gets black. Tables are rendered, if you try to select text inside them you will see it is there, but colors are all black, so you cannot see anything. There is many sites affected by this behavior, it is not related only to tables (something render'able) it does affect some static graphics too (for ex. some icons and smaller images on sites are not visible also).

So in ultra simple words, force Firefox to use custom colors (it is best to use inverted than normally so background is dark and text is bright so you will see problem easily on many sites like missing Google logo on google.com site).
I can reproduce it on Win 7 with high contrast mode but it's fixed in FF45+ and it's a dupe of bug 1244166.

You can verify yourself that it's fixed in Beta if you want: https://www.mozilla.org/en-US/firefox/beta/all/
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1244166
Google.com still does not display Google logo but tables on the link (phoronix.com) from my report are displayed properly, so it looks we have two different things here affecting Firefox.
You need to log in before you can comment on or make changes to this bug.