Closed Bug 1251298 Opened 4 years ago Closed 4 years ago

Pocket v3.0.6.1-signed blocks Nightly from starting due to bug 1248534

Categories

(Core :: XPCOM, defect)

47 Branch
defect
Not set

Tracking

()

VERIFIED FIXED
mozilla47
Tracking Status
firefox46 --- unaffected
firefox47 + fixed

People

(Reporter: Fanolian+BMO, Assigned: njn)

References

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160225030209

Steps to reproduce:

1. Try to obtain a copy of Pocket v3.0.6.1-signed (last standalone version) or v3.0.6 since it is gone from AMO or Pocket's official site. Some links can be found at http://hemenkapadia.blogspot.com/2015/12/get-old-pocket-experience-on-firefox.html. I did NOT verify if the files mentioned in the site are safe.
2. Install said extension in a new profile on Nightly 2016-02-25 build.
3. Restart Nightly.


Actual results:

Nightly does not start. No error messages is shown.
Workaround: Disable said extension in safe mode.

Note:
Pocket integrated in Nightly works properly.

From Mozregression,
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=38a98d3afba1fc744952eb7bd99f4b98750f1153&tochange=d429066578eb056ca2b9cd110cca8b63490c4d9b


I understand that Firefox should not support an outdated and abandoned extension. This standalone Pocket extension is preferred by some Pocket users over the integrated Pocket as it provides a different, if not better, user experience. I hope a fix can be considered before WONTFIX this. Thanks.
Blocks: 1248534
Has STR: --- → yes
Keywords: regression
Flags: needinfo?(n.nethercote)
Nick, did bug 1248534 change the format of .xpt files? That would be quite bad, because many extensions rely on this format being stable (even those that don't have any c++ will still sometimes ship XPTs so that they can register services).
[Tracking Requested - why for this release]: Regression
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #1)
> Nick, did bug 1248534 change the format of .xpt files? That would be quite
> bad, because many extensions rely on this format being stable (even those
> that don't have any c++ will still sometimes ship XPTs so that they can
> register services).

The on-disk format didn't change. However, I did remove almost all support for "annotations" (part 3) because none of the in-tree XPTs used them.

I'll try to reproduce and see if that patch or any of the others caused the problem.
Flags: needinfo?(n.nethercote)
It was part 8. I removed XPT_DELETE because I thought it had no useful side-effects. But as well as "deleting" (not really) the pointer, it also set it to null. So there's one pointer that's not being nulled when it should. The fix is simple.
Assignee: nobody → n.nethercote
Status: NEW → ASSIGNED
> Actual results:
> 
> Nightly does not start. No error messages is shown.
> Workaround: Disable said extension in safe mode.

BTW, I could not reproduce the behaviour of the browser not starting. What I saw was that Pocket didn't start up, i.e. there was no Pocket icon in the address bar. And with the fix the icon came back.
https://hg.mozilla.org/integration/mozilla-inbound/rev/3322ea94dacb87e3934c1c0d0fe560295fcdf9c4
Bug 1251298 - Null out |*idp| when necessary in DoInterfaceDescriptor. r=khuey.
> The on-disk format didn't change. However, I did remove almost all support
> for "annotations" (part 3) because none of the in-tree XPTs used them.

I filed bug 1251458 to reinstate handling of annotations.
https://hg.mozilla.org/mozilla-central/rev/3322ea94dacb
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
Fanolian, could you please verify this issue is fixed as expected on a latest Nightly build? Thanks.
Flags: needinfo?(Fanolian+bugzilla)
(In reply to Ritu Kothari (:ritu) from comment #10)
> Fanolian, could you please verify this issue is fixed as expected on a
> latest Nightly build? Thanks.

I can verify that Pocket v3.0.6.1-signed does not block Nightly from starting after the patch, and the extension functions properly. Thanks for the fix.
Status: RESOLVED → VERIFIED
Flags: needinfo?(Fanolian+bugzilla)
You need to log in before you can comment on or make changes to this bug.