Refactor internal printf implementation a little

RESOLVED DUPLICATE of bug 1060419

Status

()

defect
RESOLVED DUPLICATE of bug 1060419
3 years ago
2 years ago

People

(Reporter: jonco, Assigned: jonco)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Assignee

Description

3 years ago
Here's a patch to clean up a few things that bothered me in jsprf.cpp:

- remove unused members from SprintfState
- use a virtual function rather calling a function pointers
- rename things for general comprehensibility
Attachment #8723647 - Flags: review?(terrence)
Side-note, this printf implementation is cloned multiple times within Gecko.
This makes me think we should just totally rip that stuff out and use standard C methods for this.
Comment on attachment 8723647 [details] [diff] [review]
refactor-jsprf

Review of attachment 8723647 [details] [diff] [review]:
-----------------------------------------------------------------

Yes, please.
Attachment #8723647 - Flags: review?(terrence) → review+
I'm doing this same kind of thing in bug 1060419.
I'm going to close this one as a dup as that one is pretty far along.
I didn't know about this bug at the time or I would have started with it, sorry about that.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1060419
Assignee

Comment 7

2 years ago
(In reply to Tom Tromey :tromey from comment #6)
No worries, thanks for doing this.
You need to log in before you can comment on or make changes to this bug.