If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Urlbar suggestions appear on top of other windows if they are placed above Firefox window (e.g. Task Manager)

RESOLVED DUPLICATE of bug 1264983

Status

()

Firefox
Address Bar
P3
normal
RESOLVED DUPLICATE of bug 1264983
2 years ago
a year ago

People

(Reporter: arni2033, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox47 affected)

Details

(Whiteboard: [fxsearch])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8723734 [details]
screenshot 1 - Urlbar suggestions appear on top of other windows 2015.12.14 14-14-29.png

>>>   My Info:   Win7_64, Nightly 47, 32bit, ID 20160224030246
STR:
1. Open Firefox window
2. Open Windows Task Manager (Ctrl+Shift+Escape)
3. Check "On top of other windows" in Task Manager's "menu bar"
4. Click on Firefox window. Make sure it's focused
5. Press Ctrl+L, type "a", press Down key

AR:  Urlbar suggestions appear on top of Task Manager's window (screenshot 2)
ER:  Urlbar suggestions should appear below Task Manager's window, just like the rest of content

Note:
Sometimes it happens in other cases when another window is placed on top of Firefox window.
E.g. when Mozregression GUI launches new build, urlbar suggestions may be placed above that build's window. Unfortunately I didn't have time to figure out exact STR in that case.
(Reporter)

Comment 1

2 years ago
Created attachment 8723735 [details]
screenshot 2 - Urlbar suggestions appear on top of other windows 2016.02.21 05-17-51.png
This is totally expected behavior of the popup window. Why is this a bug? Just because it is different from Chrome?
(Reporter)

Comment 3

2 years ago
(In reply to Masatoshi Kimura [:emk] from comment #2)
> This is totally expected behavior of the popup window.
1) You implying that urlbar suggestions must be implemented as popup window
2) The question is what is totally expected behavior of urlbar suggestions
> Why is this a bug?
See screenshot 1 which caught me off guard. That doesn't look expected to me. Do you think it should
work like this, appear out of nowhere on top of other window's content? I believe it shouldn't
> Just because it is different from Chrome?
I haven't checked Chrome behavior yet, but if it works as expected - then good for it. Nice app.
(Reporter)

Comment 4

2 years ago
Well, I wasn't filing all these bugs for quantity... I'm just listing everything I encountered.
Screenshot 1 is surely undesired, but it may not be completely Firefox' fault.

If I try to think logically, the expected behavior of urlbar is the same as Windows Explorer's
address bar (or Internet Explorer's urlbar), because in the past Firefox was just copying some basic behavior of default applications and providing some extra features.
So location bar behavior matches the expectations on Win7. The only thing should be checked is how those two bars work on newer versions of Windows. These are my thoughts.
Status: NEW → UNCONFIRMED
Ever confirmed: false
(Reporter)

Updated

2 years ago
See Also: → bug 1255019
Pretty sure this is due to setting level=parent on the panel but I haven't investigated.
Blocks: 1264983
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Priority: -- → P3
Whiteboard: [fxsearch]
(Reporter)

Comment 6

a year ago
No, it was _fixed_ by bug 1264983. That bug basically asked for the same thing as this
Status: NEW → RESOLVED
Last Resolved: a year ago
Keywords: regression
Resolution: --- → DUPLICATE
Duplicate of bug: 1264983
You need to log in before you can comment on or make changes to this bug.