Closed Bug 1251509 Opened 5 years ago Closed 5 years ago

backspace key makes the cursor jump to the very beginning of a text string

Categories

(Firefox for Android Graveyard :: Text Selection, defect)

defect
Not set
normal

Tracking

(firefox45 fixed, firefox46 fixed, firefox47 unaffected, fennec45+)

RESOLVED DUPLICATE of bug 1241558
Tracking Status
firefox45 --- fixed
firefox46 --- fixed
firefox47 --- unaffected
fennec 45+ ---

People

(Reporter: dholbert, Unassigned)

Details

(Keywords: regression)

STR:
 1. Visit https://pastebin.mozilla.org/8861264
 (or just visit the pastebin homepage and type in a long string of characters)

 2. Tap somewhere in the middle of the long string of a's in the textarea, to place the cursor there.

 3. Press backspace.

EXPECTED RESULTS:
One character should be backspaced. Cursor should stay between that backspaced character's neighbors.

ACTUAL RESULTS:
One character is backspaced, BUT then the cursor jumps to the very beginning of the textarea.  (In other examples I've tried -- usually after I type some more at the end and repeat my STR -- the cursor jumps to the very end, instead.)

I can reproduce this in Nightly 47, Aurora 46, and Beta 45, but not in Release 44. So, it looks like this is a regression that we're getting pretty close to shipping.
Screencast, using Firefox Beta 45.0b9: https://www.youtube.com/watch?v=-KS3L9G3rYU
tracking-fennec: --- → ?
So when I filed this bug a few minutes ago, I could reproduce it in Nightly, but now I'm having trouble getting it to reproduce in a freshly-installed recent Nightly (from mozregression)

So I'm not sure what's going on, and we might have fixed this on trunk... I can definitely still reproduce in Beta & Aurora, though I'm not sure if that's because of something profile-specific [somewhat unlikely as I don't use Beta/Aurora often] or because this is a bug we fixed on trunk.
(In reply to Daniel Holbert [:dholbert] from comment #2)
> So when I filed this bug a few minutes ago, I could reproduce it in Nightly,
> but now I'm having trouble getting it to reproduce in a freshly-installed
> recent Nightly (from mozregression)

Mystery solved -- I was stuck on an old-ish Nightly version (2016-01-27) when I filed this bug -- possibly as fallout from an earlier mozregression run leaving me with a weird nightly package installed? Not sure.

Anyway, my Aurora and Beta builds do seem to be up to date, and they do reproduce this. So while this seems to be fixed in Nightly, we do seem to be on track to ship this regression in Firefox 45 and 46.

Worth considering backing out whatever regressed this on those branches, or alternately backporting whatever fixed this on Nightly47 to those branches.
Component: General → Text Selection
capella & TYLin: Can you reproduce on Aurora / Beta, and do you have any idea what might've regressed this on those channels? (& what might've fixed it on Nightly)
Was thinking Bug 1241558 - backspace deletes text not where the cursor is ... haven't check for sure
Oh, jchen never promoted?
Thanks -- yeah, seems likely that this is the same underlying issue as Bug 1241558. I just needinfo'd jchen to ask about uplift there.

(Side-note: this bug is hard to test on Nightly builds [new and old] because it's hard to place the cursor in the middle of the text -- I filed bug 1251519 on that.   You can work around that by toggling layout.accessiblecaret.enabled to false.)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1241558
tracking-fennec: ? → 45+
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.