The homepage button is enabled in browser when homepage is not set.

RESOLVED FIXED

Status

Firefox OS
Gaia::TV
RESOLVED FIXED
2 years ago
10 months ago

People

(Reporter: oscartsai@allion.com, Assigned: danhuang)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.5 fixed, b2g-master verified)

Details

(Whiteboard: [ft:conndevices], URL)

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

2 years ago
[Description]
The homepage button is enabled in browser when homepage is not set.

[Testing Steps]
1. Launch Browser.
2. Move cursor to the Menu icon and press OK.
3. Select "Settings" and press OK.
4. Select "Homepage" and press OK.
5. Press Up twice to focus on text field. 
6. Press Right and press OK to clear text.
7. Press Down twice and press OK.
8. Press Back.
9. Move cursor to Homepage icon.
10. The homepage button is highlighted and enabled.


[Expected result]
10. The homepage should be gray out.

[Actual result]
10. The homepage button is highlighted and enabled.
Homepage button is enabled although there is no action when pressing homepage button.
Please refer to: https://youtu.be/2l8G4Y4rg04


[Build Info]
Environment: 2.6 Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/1ad93502b639e5c335c15c97882a4c516b2ffa23
gecko:
https://hg.mozilla.org/mozilla-central/rev/c1e0d1890cfee9d86c8d566b0490053f21e0afc6

Comment 1

2 years ago
please help to verify if 2.5 has this issue or not, if yes then nominate it as blocker
Keywords: qawanted

Comment 2

2 years ago
This issue is also observed on v2.5.
[Build Info]
gaia:
https://github.com/mozilla-b2g/gaia/commit/b059a19c4cb615e16174735662199e6769cee393
gecko:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/38e6a8bdf412a947418ffffc54c4821fe6103f9f
mulet:
https://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/9d519d3bedacb7f5ce467f4c6bef7ff55ff3b0f3

Updated

2 years ago
blocking-b2g: --- → 2.5?
status-b2g-v2.5: --- → affected
Keywords: qawanted
Hi Yifan,
Could you please take a look? Thank you.
Flags: needinfo?(yliao)
Dan, could you help here?
Assignee: nobody → dhuang
blocking-b2g: 2.5? → 2.5+
Flags: needinfo?(yliao) → needinfo?(dhuang)
(Assignee)

Comment 5

2 years ago
Yes, Got it!
Flags: needinfo?(dhuang)
(Assignee)

Comment 6

2 years ago
Hi Tori,

Could you provide your opinion about how browser should interact when the homepage is set to empty?
I had tested the scenario on firefox desktop. 
When the homepage setting field is empty, click homepage button will go to the Mozilla home page.
Flags: needinfo?(tchen)

Comment 7

2 years ago
Hi Dan, I prefer this behavior:
When the homepage setting field is empty, disable the save button. So user can't save when the field is empty.
Flags: needinfo?(tchen)

Comment 8

2 years ago
Created attachment 8726111 [details] [review]
[gaia] danhuang1202:1251546_disable_ok_button_when_homepage_is_empty > mozilla-b2g:master
(Assignee)

Comment 9

2 years ago
Comment on attachment 8726111 [details] [review]
[gaia] danhuang1202:1251546_disable_ok_button_when_homepage_is_empty > mozilla-b2g:master

Hi Yi-Fan, please help review. This patch add input check for homepage setting. And also if the input is invalid, disable the ok button. Thanks.
Attachment #8726111 - Flags: review?(yliao)
Comment on attachment 8726111 [details] [review]
[gaia] danhuang1202:1251546_disable_ok_button_when_homepage_is_empty > mozilla-b2g:master

Just a nit on Github. Thanks!
Attachment #8726111 - Flags: review?(yliao) → review+
(Assignee)

Comment 11

2 years ago
Thanks for the review!
Merge in master: https://github.com/mozilla-b2g/gaia/commit/af37a5c49c688dac4f0f8fccab113f684b2d6c54
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 12

2 years ago
Comment on attachment 8726111 [details] [review]
[gaia] danhuang1202:1251546_disable_ok_button_when_homepage_is_empty > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1187806
[User impact] if declined: The homepage url can been set to empty.
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=b20e83218be4c0dba15772e4266c4074a3ba340d
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: None
Attachment #8726111 - Flags: approval-gaia-v2.5?
Hi Oscar,
Could you please verify this bug? Thank you.
Flags: needinfo?(oscartsai)

Comment 14

2 years ago
This issue is verified on following v2.6 build and the result is PASS.
The OK button is disabled when homepage is empty.
[Build Info]
gaia:
https://github.com/mozilla-b2g/gaia/commit/af37a5c49c688dac4f0f8fccab113f684b2d6c54
gecko:
https://hg.mozilla.org/mozilla-central/rev/b6acf4d4fc20431a8ae14bf32cdc6e43a9c0f9ad

Updated

2 years ago
status-b2g-master: affected → verified

Comment 15

2 years ago
Comment on attachment 8726111 [details] [review]
[gaia] danhuang1202:1251546_disable_ok_button_when_homepage_is_empty > mozilla-b2g:master

Approve for TV 2.5
Attachment #8726111 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+

Updated

2 years ago
Blocks: 1256220

Comment 16

2 years ago
Dan,

please help to merge to 2.5 branch. Thanks
Flags: needinfo?(dhuang)

Comment 17

2 years ago
Created attachment 8731533 [details] [review]
[gaia] mozilla-b2g:revert-34124-1251546_disable_ok_button_when_homepage_is_empty > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8731533 - Attachment is obsolete: true
Flags: needinfo?(dhuang)
(Assignee)

Updated

2 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

2 years ago
Blocks: 1255325
(Assignee)

Comment 18

2 years ago
revert: https://github.com/mozilla-b2g/gaia/commit/49aa98cbb09be9fec8275886a28edfc7395f6181

Comment 19

2 years ago
Created attachment 8731571 [details] [review]
[gaia] danhuang1202:1251546_disable_ok_button_and_show_input_validity_when_homepage_is_empty > mozilla-b2g:master
(Assignee)

Comment 20

2 years ago
Comment on attachment 8731571 [details] [review]
[gaia] danhuang1202:1251546_disable_ok_button_and_show_input_validity_when_homepage_is_empty > mozilla-b2g:master

Hi Yi-Fan, please help review again. The difference this patch and last one are: 1. hide input invalid state when click restore-default button. 2. reset active element when setting dialog open. Thanks.
Attachment #8731571 - Attachment description: [gaia] danhuang1202:1251546_disable_ok_button_when_homepage_is_empty > mozilla-b2g:master → [gaia] danhuang1202:1251546_disable_ok_button_and_show_input_validity_when_homepage_is_empty > mozilla-b2g:master
Attachment #8731571 - Flags: review?(yliao)

Updated

2 years ago
Attachment #8731571 - Flags: review?(yliao) → review+
(Assignee)

Comment 21

2 years ago
Thanks for the review!
Merge in master: https://github.com/mozilla-b2g/gaia/commit/5ad26b1c0d0c719b773a9e152fef83a8c6dfc786
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 22

2 years ago
Comment on attachment 8731571 [details] [review]
[gaia] danhuang1202:1251546_disable_ok_button_and_show_input_validity_when_homepage_is_empty > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Bug 1187806
[User impact] if declined: The homepage url can been set to empty.
[Testing completed]: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=c9082fb9bf62c5aa80f30e3e76a01311fa633832
[Risk to taking this patch] (and alternatives if risky): None
[String changes made]: None
Attachment #8731571 - Flags: approval-gaia-v2.5?

Comment 23

2 years ago
Comment on attachment 8731571 [details] [review]
[gaia] danhuang1202:1251546_disable_ok_button_and_show_input_validity_when_homepage_is_empty > mozilla-b2g:master

Approve for TV 2.5
Attachment #8731571 - Flags: approval-gaia-v2.5? → approval-gaia-v2.5+

Comment 24

2 years ago
Created attachment 8733268 [details] [review]
[gaia] danhuang1202:v2.5 > mozilla-b2g:v2.5

Comment 25

2 years ago
Created attachment 8733275 [details] [review]
[gaia] danhuang1202:v2.5 > mozilla-b2g:v2.5
(Assignee)

Updated

2 years ago
Attachment #8733268 - Attachment is obsolete: true
(Assignee)

Comment 26

2 years ago
Merge in v2.5,
https://github.com/mozilla-b2g/gaia/commit/10661e244812717312d23a2cc014e789e2d33304

Updated

2 years ago
status-b2g-v2.5: affected → fixed
Flags: needinfo?(oscartsai)
You need to log in before you can comment on or make changes to this bug.