Back to home page directly when launching an App in Apps without network connection and press "close" button in error page.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
8 months ago

People

(Reporter: oscartsai, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.5 affected, b2g-master affected)

Details

(Whiteboard: [ft:conndevices], URL)

(Reporter)

Description

3 years ago
[Description]
Back to home page directly when launching an App in Apps without network connection and press "close" button in error page.

[Testing Steps]
1. Launch Apps 
2. Launch "Web Apps" 
3. Press Option button on any app to "Add to Apps"
4. Set device offline 
5. Press Home and Launch Apps again
6. Press OK to launch the added app
8. The connection error page is shown
9. Select "Close" button to close the app
10. Back to Home page directly.


[Expected result]
10. It should close the app and return to Apps page.

[Actual result]
10. Back to Home page directly.
Please refer to: https://youtu.be/L1QD7yMGUN0



[Build Info]
Environment: 2.6 Simulator
gaia:
https://github.com/mozilla-b2g/gaia/commit/1ad93502b639e5c335c15c97882a4c516b2ffa23
gecko:
https://hg.mozilla.org/mozilla-central/rev/c1e0d1890cfee9d86c8d566b0490053f21e0afc6

Comment 1

3 years ago
I think this is an undefined behaviour. Tori, please help to confirm the expected result here, thanks.
Flags: needinfo?(tchen)

Comment 2

3 years ago
@Jack
This is about network offline case. Could you define the expected result?
Flags: needinfo?(tchen) → needinfo?(jalin)

Comment 3

3 years ago
Dear Oscartsai,

I think I have defined this behaviour. Please see the spec. as the link below (BTW, I have added more explanation in the spec.),
https://drive.google.com/open?id=0BwbmH5cX2W6OWThiTmhhd3ZSUm8

I totally agree your suggestion. 
[Expected result]
10. It should close the app and return to Apps page.

The logic should be "Back to the place where the user triggered the app"

Please let me know if you have any questions.
Thank you
Jack
Flags: needinfo?(jalin)

Comment 4

3 years ago
Hi Oscar, please help to verify if v2.5 has this issue or not, if yes please nominate it as blocker
Flags: needinfo?(oscartsai)
Keywords: qawanted
(Reporter)

Comment 5

3 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 2.5?
status-b2g-v2.5: --- → affected
Flags: needinfo?(oscartsai)
Keywords: qawanted

Comment 6

3 years ago
Dan and Luke, I remember we do window.close() on the network error screen when the user click 'Close' button? If so, back to Smart Home is an expected behavior?
Flags: needinfo?(lchang)
Flags: needinfo?(dhuang)

Comment 7

3 years ago
We call window.close() when click close button.
Flags: needinfo?(dhuang)
Yes, it's by design. Killing any app launching from Apps should always lead users to the landing app (which is Smart Home in our build). 

As far as I know, the system app is not able to distinguish whether an app is killed by itself or by the error pages. That is, changing this behavior will affect not only error pages but also the whole system. I would suggest not doing this for now.


Hi Jack, what do you think?
Flags: needinfo?(lchang) → needinfo?(jalin)

Comment 9

3 years ago
We won't take any risky change at this stage, so it's not a blocker.

Luke, I remember we have a system-wise back button bug, could you dup this one to that one? Thanks.
blocking-b2g: 2.5? → ---
Flags: needinfo?(jalin) → needinfo?(lchang)

Comment 10

3 years ago
This issue is not related to back button behaviour. It's due to the returned original page. Current behaviour is back to Home instead of app deck while closing the offline dialogue even this app is launched from app deck.
Yes, we have bug 1225748 of the back button. However, I agree with Mike that these two bugs are a bit different.

This bug is more like to discuss which app needs to be shown next when a foreground app has been killed, no matter who kills it. So I suggest making bug 1225748 focus on closing apps by the back button and using this bug to discuss what's the next step after apps are closed.
Flags: needinfo?(lchang)
See Also: → bug 1225748

Comment 12

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.