Page in reader view is displayed blank after Firefox is reopened with "Always restore" enabled

VERIFIED FIXED in Firefox 46

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: TeoVermesan, Assigned: jchen)

Tracking

({regression})

47 Branch
Firefox 47
ARM
Android
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox45 wontfix, firefox46+ verified, firefox47+ verified, fennec46+)

Details

Attachments

(2 attachments)

Posted image index.png
Steps to reproduce:
1. Go to news.google.com
2. Tap on an article
3. Enter reader view
4. Set up "Always restore" on "Restore Tabs"
5. Close Firefox
6. Reopen it

Expected results:
- Firefox is restored and the page is displayed in reader view

Actual results:
- Page is displayed blank

Note:
regression:
good build: 01-02
bad build: 02-02

pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=941033a51983ddec2d99aa9f868a54c0196a4075&tochange=5f9ba76eb3b1fd9377bbdb4cc2f98a7e75eabdfb
Jim this might be fallout from  Bug 1243049.
tracking-fennec: --- → ?
Flags: needinfo?(nchen)
Yeah looks like it.
Assignee: nobody → nchen
Status: NEW → ASSIGNED
Flags: needinfo?(nchen)
When restoring reader mode tabs, we need the reader mode frame script to
be loaded early, otherwise the restored page won't be loaded correctly.
The safest fix seems to be simply not delay-loading the frame script.
Attachment #8725786 - Flags: review?(margaret.leibovic)
[Tracking Requested - why for this release]: This is actually a regression from bug 1173379. Earlier releases are affected, but unlike on nightly, the bug is not easily reproducible on earlier releases.
Attachment #8725786 - Flags: review?(margaret.leibovic) → review+
tracking-fennec: ? → 46+
https://hg.mozilla.org/mozilla-central/rev/b891c43b673e
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Comment on attachment 8725786 [details] [diff] [review]
Don't delay loading reader mode frame script (v1)

Approval Request Comment
[Feature/regressing bug #]: Bug 1173379
[User impact if declined]: Cannot restore reader mode pages on startup
[Describe test coverage new/current, TreeHerder]: Tested locally
[Risks and why]: No risk; the fix reverts a change and there should be no impact in functionality.
[String/UUID change made/needed]: None
Attachment #8725786 - Flags: approval-mozilla-aurora?
Regression from 41 but sounds like it is more noticeable in recent versions. Tracking for 46+.
Comment on attachment 8725786 [details] [diff] [review]
Don't delay loading reader mode frame script (v1)

We want reader view to work, please uplift to aurora. This should make it to the beta 1 build on Monday.
Attachment #8725786 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed on Aurora 47.0a2 (2016-03-11) and on Firefox 46 Beta 1
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.