Closed Bug 1251661 Opened 4 years ago Closed 4 years ago

Add probe to determine activity of saved and loaded RV items in Bookmark panel

Categories

(Firefox for Android :: Metrics, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1246712

People

(Reporter: barbara, Unassigned)

References

(Blocks 1 open bug)

Details

We want to understand activity and usage around items being a) saved and b) loaded to the Bookmark panel in RV mode and non-RV mode.

We basically want to determine the different types of items in the Bookmarks panel.

See more here: https://bugzilla.mozilla.org/show_bug.cgi?id=1251058#c1
Summary: Add probe to determine activity of saved and loaded RV items in Bookmarkspanel → Add probe to determine activity of saved and loaded RV items in Bookmark panel
We already have ACTION and SAVE/UNSAVE information about bookmarks and reading list. Since the buttons for Reading List are going away, I would suggest we use a different Extra in the "Star" (or any other UI element that saves a bookmark as a RV item) to indicate it's being saved/unsaved as a reader item.

Current:
* Save/Unsave a bookmark (SAVE/UNSAVE, method, "bookmark")
* Save/Unsave a reading list item (SAVE/UNSAVE, method, "reading_list")

Propose:
* Save/Unsave a bookmark from ReaderView (SAVE/UNSAVE, method, "bookmark-readerview")

Basically, just tweak the extra to something we feel OK with. Maybe we don't need "bookmark" in there at all and just use "readerview".

"method" in all of these can be menu, button, contextmenu - whatever the UI element is.
(In reply to Mark Finkle (:mfinkle) from comment #1)

> Propose:
> * Save/Unsave a bookmark from ReaderView (SAVE/UNSAVE, method,
> "bookmark-readerview")

ahunt can add this while he's making the bookmark star work in reader view.
Flags: needinfo?(ahunt)
We already did this in Bug 1246712, closing as duplicate!
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(ahunt)
Resolution: --- → DUPLICATE
Duplicate of bug: 1246712
You need to log in before you can comment on or make changes to this bug.