Inline frames (<iframe>) always drawn on top

VERIFIED DUPLICATE of bug 91516

Status

Core Graveyard
GFX
VERIFIED DUPLICATE of bug 91516
16 years ago
9 years ago

People

(Reporter: Brian Rogers, Assigned: Kevin McCluskey (gone))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Iframes always draw on top of other content, even when they shouldn't.

One example is if you use absolute positioning to place a div on top of an
iframe.  The iframe should in this case be clipped by the div, but it is drawn
on top.
It should respect the same ordering rules as any other element, that is, later
elements in the html go on top.

Z-index does not work to fix this ordering, and setting -moz-opacitiy below 1.0
does not allow you to see below the iframe.

This is on Mozilla build 2002021108.
(Reporter)

Comment 1

16 years ago
Created attachment 69214 [details]
simple testcase

Attaching simple testcase.  Right should match left.  The green box should be
on top.

Comment 2

16 years ago
This problem seems that is going to be fixed (let's hope so) quite soon in bug
91516 "IFRAMEs do not respect z-index of other, non-iframe content"

*** This bug has been marked as a duplicate of 91516 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
vrfy
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.