[WebExtensions] windows.create() does not seem to support all documented options

RESOLVED DUPLICATE of bug 1213484

Status

defect
RESOLVED DUPLICATE of bug 1213484
3 years ago
10 months ago

People

(Reporter: merijn.de.jonge, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.116 Safari/537.36

Steps to reproduce:

Create a new window in a javascript extension:
browser.windows.create({ url: request.url, focused:false}, function (w) { });


Actual results:

firefox issues an error:
Type error for parameter createData (Property "focused" is unsupported by Firefox) for windows.create.


Expected results:

The documentation clearly describes this option:
https://developer.mozilla.org/en-US/Add-ons/WebExtensions/API/Windows/create

This option is also in line with chrome. So there should be no error generated.

BTW a simular error is raised for the "type" option. E.g. when specifying 'type: popup'.
(Reporter)

Updated

3 years ago
Summary: windows add-on API documents but does not seem to support options → windows add-on API function "create" does not seem to support all documented options

Updated

3 years ago
Component: Untriaged → WebExtensions
Product: Firefox → Toolkit
Summary: windows add-on API function "create" does not seem to support all documented options → [WebExtensions] windows.create() does not seem to support all documented options
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: webext-windows

Updated

10 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.