calendar invites cannot be configured to remain in inbox

RESOLVED WORKSFORME

Status

Calendar
E-mail based Scheduling (iTIP/iMIP)
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Neogeek83, Unassigned)

Tracking

Lightning 4.0.5.2
x86_64
Linux

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/48.0.2564.116 Safari/537.36

Steps to reproduce:

 - Received an invite
 - Clicked any of the options (Accept, Tentative, Decline)


Actual results:

The invite disappears, even when clicking tentative.


Expected results:

There doesn't appear to be a config option(even an advanced config setting) to allow the invite to remain in the inbox (marked as responded to). It would be beneficial to allow different user flows (ie, managing the response from the inbox vs forcing users over to the calendar to see what status they are).
(Reporter)

Updated

2 years ago
Component: Folder and Message Lists → E-mail based Scheduling (iTIP/iMIP)
Keywords: calendar-integration, mail-integration, ux-control, ux-efficiency
OS: Unspecified → Linux
Product: Thunderbird → Calendar
Hardware: Unspecified → x86_64
Version: 38 Branch → Lightning 4.0.5.2
(Reporter)

Updated

2 years ago
See Also: → bug 512657
(Reporter)

Updated

2 years ago
See Also: → bug 829582
(Reporter)

Updated

2 years ago
See Also: → bug 379200

Comment 1

2 years ago
What do you mean with the invitation disappears? The whole message or are you just referring to the buttons on the blue bar?

Regarding your description of the expected result, keep in mind that the invitation just represents the event at the time of receiving. It almost does not represent the current state of the event, especially this is true after replying or receiving an update later. You can change the participation status by clicking on the details button.  

The other referenced bugs are not related to the report. If you have to add something to those bugs (except a me too comment), please comment there.
Keywords: calendar-integration, mail-integration, ux-control, ux-efficiency
(Reporter)

Comment 2

2 years ago
(In reply to MakeMyDay from comment #1)
> What do you mean with the invitation disappears? The whole message or are
> you just referring to the buttons on the blue bar?

When I click "Accept" "Tentative" or "Decline" in the bar across the top of the message pane, the email message that contains the invite is deleted (doesn't goto trash even). 

> Regarding your description of the expected result, keep in mind that the
> invitation just represents the event at the time of receiving. It almost
> does not represent the current state of the event, especially this is true
> after replying or receiving an update later. You can change the
> participation status by clicking on the details button.  


I understand that the initial invite is a snapshot in time, as are all other email messages. This issue is really an objection to an application deleting email sent to me from other parties (even if it is mostly a blank one with an invite.ics attached) out from under me with no option to turn the feature off.


> The other referenced bugs are not related to the report. If you have to add
> something to those bugs (except a me too comment), please comment there.

Forgive my ignorance with referencing the other bugs, this is my first report for this project, so I'm learning as I go along. That having been said, this is a user experience related bug, dealing with the acceptance of an invite received through mail and how it appears to the user and persists.  Thus referencing a bug related to the UX of event accept/decline and linking to an event in a seamless way in the mail viewer seemed appropriate (bugs #512657 & #829582). Bug #379200 I thought would be appropriate due to how the message should appear in the inbox view, but I can see that is a more tangential connection.

I also noticed you have deleted the keywords I associated with the issue. I added those after reading the description for each. Are we not supposed to give keywords for issues when we fill them out?

Comment 3

2 years ago
(In reply to Neogeek83 from comment #2)
> When I click "Accept" "Tentative" or "Decline" in the bar across the top of
> the message pane, the email message that contains the invite is deleted
> (doesn't goto trash even). 

Hmm, this is quite suprising as we currently don't have implemented (there exists a bug to implement it, but that would be configurable then). Are there any messages in the error console when this is happening? What other addons do you have installed? Do you observe that behaviour also with all of them disabled?

> Forgive my ignorance with referencing the other bugs, this is my first
> report for this project, so I'm learning as I go along. That having been
> said, this is a user experience related bug, dealing with the acceptance of
> an invite received through mail and how it appears to the user and persists.
> Thus referencing a bug related to the UX of event accept/decline and linking
> to an event in a seamless way in the mail viewer seemed appropriate (bugs
> #512657 & #829582). Bug #379200 I thought would be appropriate due to how
> the message should appear in the inbox view, but I can see that is a more
> tangential connection.
> 
> I also noticed you have deleted the keywords I associated with the issue. I
> added those after reading the description for each. Are we not supposed to
> give keywords for issues when we fill them out?

No need to excuse here, I could have explained better. Referencing other bugs is absolutely ok to help resolve the reported issue. The thumb rule is one bug per issue and it's much appreciated to not mix the issues, because this just makes bugs less readable. Your intention was probably more a back reference. But also for that the bugs are not closely relatwd from a developer perspective.

These keywords are basically not used in the calendar projwct, so need to set them (although doing so doesn't hurt - but just meaning nothing)
(Reporter)

Comment 4

2 years ago
(In reply to MakeMyDay from comment #3)
> Hmm, this is quite suprising as we currently don't have implemented (there
> exists a bug to implement it, but that would be configurable then). Are
> there any messages in the error console when this is happening? What other
> addons do you have installed? Do you observe that behaviour also with all of
> them disabled?

Currently installed:
 - Display Mail User Agent 1.7.0
 - Enigmail 1.9
 - Exchange EWS Provider 3.5.0-beta1
 - Google Tasks Sync 0.5.2
 - Lightning 4.0.5.2
 - Messaging Menu and Unity Launcher integration 1.3.1
 - Provider for Google Calendar 2.7

The issue occurs when I response to an invite received to the account I have associated with an exchange calendar. I just tried creating an event on the exchange calendar and sending to my Google email and see that the invite removal is not present when I go that way. I've got to goto work now, but will try to run a test(exchange->exchange) while monitoring the console and post back results here.

Comment 5

2 years ago
That is what I expected. Deleting messages after responding is an Outlook/Exchange standard bevaviour (although I think that is configurable there). Please file an according bug with EWD Provider in their issue tracke - issues with that addon ate not tracked here in BMO.

But to help others who are searching here, please add an according link to this bug.
(Reporter)

Comment 6

2 years ago
For others looking for the answer to this, I have created an issue on Exchange EWS Provider issues tracker:
See https://github.com/Ericsson/exchangecalendar/issues/438

Comment 7

2 years ago
Thanks for adding the reference. I close this bug WFM as this is an issue in the addon only.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.