Closed Bug 1251792 Opened 4 years ago Closed 4 years ago

Add fetch-request-css-images.https.html to wpt manifest

Categories

(Core :: DOM: Service Workers, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla47
Tracking Status
firefox47 --- fixed

People

(Reporter: bkelly, Assigned: ehsan)

References

Details

(Whiteboard: btpp-active)

+++ This bug was initially created as a clone of Bug #1188822 +++

Bug 1188822 added fetch-request-css-images.https.html, but failed to update the wpt manifest.  It needs to be added to the manifest.

The test fails, but this is not completely unexpected.  It was broken out from a test with known expected failures.  It may just need an appropriate .ini file to note these expected failures.

Of course, if we can make it pass, thats better.
Duplicate of this bug: 1251878
I happened to come across this, and pushed a fix.
Assignee: dlee → ehsan
Backed out for failing the test (as W(4) and W(8)):

Backout: https://hg.mozilla.org/integration/mozilla-inbound/rev/9f95384e8d21

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&revision=7314001ba54c
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=22575993&repo=mozilla-inbound
14:34:12     INFO - TEST-START | /_mozilla/service-workers/service-worker/fetch-request-css-images.https.html
14:34:13     INFO - TEST-UNEXPECTED-FAIL | /_mozilla/service-workers/service-worker/fetch-request-css-images.https.html | Verify FetchEvent for resources. - assert_equals: credentials of CSSImage load (url:https://web-platform.test:8443/_mozilla/service-workers/service-worker/resources/dummy?test1 type:backgroundImage) must be include. expected "include" but got "same-origin"
14:34:13     INFO - channel.port1.onmessage<@https://web-platform.test:8443/_mozilla/service-workers/service-worker/fetch-request-css-images.https.html:67:17
14:34:13     INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1382:20
14:34:13     INFO - Test.prototype.step_func/<@https://web-platform.test:8443/resources/testharness.js:1406:20
14:34:13     INFO - EventHandlerNonNull*@https://web-platform.test:8443/_mozilla/service-workers/service-worker/fetch-request-css-images.https.html:53:41
14:34:13     INFO - @https://web-platform.test:8443/_mozilla/service-workers/service-worker/fetch-request-css-images.https.html:51:18
14:34:13     INFO - promise callback*@https://web-platform.test:8443/_mozilla/service-workers/service-worker/fetch-request-css-images.https.html:45:5
14:34:13     INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1382:20
14:34:13     INFO - async_test@https://web-platform.test:8443/resources/testharness.js:513:13
14:34:13     INFO - @https://web-platform.test:8443/_mozilla/service-workers/service-worker/fetch-request-css-images.https.html:35:1
Flags: needinfo?(ehsan)
Turns out the name used in the test didn't match the name in the ini file!
Flags: needinfo?(ehsan)
Whiteboard: btpp-active
https://hg.mozilla.org/mozilla-central/rev/7f68fa9b0f9c
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla47
You need to log in before you can comment on or make changes to this bug.