Can no longer zoom on standalone images that are not at intrinsic size

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
3 years ago
9 months ago

People

(Reporter: bzbarsky, Unassigned)

Tracking

({regression})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox47+ fixed)

Details

[Tracking Requested - why for this release]: UX regression

STEPS TO REPRODUCE:

1)  Load http://i.imgur.com/Kwlo6.jpg
2)  Try to zoom with either mouse, or Ctrl/Cmd-+ or the View menu

EXPECTED RESULTS: Can zoom in on the image even though it's not at intrinsic size

ACTUAL RESULTS: Zooming is ignored.

This is a regression from bug 1145903, looks like.
Flags: needinfo?(tnikkel)
Flags: needinfo?(bgirard)
Keywords: regression
backed out bug 1145903 for this.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(tnikkel)
Flags: needinfo?(bgirard)
Resolution: --- → FIXED
Umm. This is interesting. For this test case the new behavior is better:
http://i.imgur.com/Kwlo6.jpg

When you Cmd-+ without my patch the top is cut off and you cannot see the top of the image. With my patch the zoom is disabled in that mode and you need to zoom click on the image to zoom the image. Therefore you can't perform the Cmd-+ zoom that cuts off the image.

I think both behaviors are busted.
> When you Cmd-+ without my patch the top is cut off

That's bug 1251280 and is a recent regression. I'll fix it in the next few days; it was while trying to diagnose it that I ran into this bug...

> I think both behaviors are busted.

Yes, they are.  :)
Ahh ok. I was fiddling trying to get the right fully right behavior but I'll wait for bug 1251280 to be fixed and try again. FWIW disabling width/height 100% in my patch matches what I see in Nightly. I'll block bug 1145903 on bug 1251280.
This looks like it was fixed by the patch back out mentioned in comment 1.

Updated

9 months ago
Product: Core → Core Graveyard

Updated

9 months ago
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.