Closed Bug 1251823 Opened 4 years ago Closed 4 years ago

Fail add breakpoint using right-click menu on the current CodeMirror-line

Categories

(DevTools :: Debugger, defect)

defect
Not set

Tracking

(firefox44 affected, firefox45 affected, firefox46 affected, firefox47 fixed, firefox-esr38 affected)

RESOLVED FIXED
Firefox 47
Tracking Status
firefox44 --- affected
firefox45 --- affected
firefox46 --- affected
firefox47 --- fixed
firefox-esr38 --- affected

People

(Reporter: magicp.jp, Assigned: jlong)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160226030256

Steps to reproduce:

1. Start Nightly (reproduce in Firefox 32 or later version)
2. Go to bugzilla.mozilla.org
3. Open DevTools > Debugger
4. Select JS file
5. Select a line and open right-click menu on the CodeMirror (not on the line number)
6. Select "Add Breakpoint"


Actual results:

"NaN" is displayed as breakpoint. (or cannot add breakpoint in some versions).

Regression range:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=58c5a3427997&tochange=2893f60d5903



Expected results:

Breakpoint could be added by right-click menu on the current CodeMirror-line.
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Developer Tools: Debugger
OS: Unspecified → All
Hardware: Unspecified → All
In step 5, if select two or more lines, then freeze Firefox.
Flags: needinfo?(jlong)
This is interesting. I don't think this ever worked, or at least wasn't introduced in my refactoring. I will figure out a fix.
Assignee: nobody → jlong
Flags: needinfo?(jlong)
Attached patch 1251823.patchSplinter Review
The problem is that you can reach the context menu by either right-clicking on the gutter or the text. If you right-click the text, it moves the cursor, but the gutter doesn't. So we need to track which place was clicked so that we can determine the right location to add a breakpoint.
https://hg.mozilla.org/mozilla-central/rev/7b5e74921ea3
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 47
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.