forecast.io website causes Firefox to have high CPU usage

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Greg, Unassigned)

Tracking

44 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160209234642

Steps to reproduce:

Visit webpage http://forecast.io/#/f/40.7142,-74.0064


Actual results:

Firefox raises CPU usage to high level.


Expected results:

CPU usage should not go up so high.

Comment 1

2 years ago
WFM in Fx45b10 Win10.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
Hi Greg,

I haven't managed to reproduce this issue on the latest release(44.0.2) nor latest Nightly(47.0a1). I opened your provided link and the CPU didn't go up more than 5% on Ubuntu 14.04.

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160229030448

Can you please try to reproduce this on the latest release(44.0.2) and latest Nightly(47.0a1) and provide the results? When doing this, please try to reproduce with a new clean Firefox profile, maybe even in safe mode, as some of this issues may be caused by third party installed add-ons or custom settings(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thanks,
Paul.
Flags: needinfo?(gwmali01)
(Reporter)

Comment 3

2 years ago
I just tried it again with Fx 45.0, same issue. 'Top' is showing CPU between 56-76%. Using Ubuntu Desktop 14.04 with default Unity shell (fully up to date). I disabled the few extensions I have, issue still occurs. Any insight into why my machine is doing this?
Hi Greg,

Did creating a new profile or safe mode make any difference?

Thanks,
Paul.

Comment 5

2 years ago
Something is going on with forecast.io


Loading it up in fresh profiles and both Beta and nightly produce very high CPU usage for loading a single page.

The RAM usage maxes out within 1-2 minutes.

Comment 6

2 years ago
Created attachment 8734015 [details]
process stats from latest nightly running fresh profile

process stats from latest nightly running fresh profile and loading forecast.io

The "ramp" shows when the forecast.io page is loaded

Comment 7

2 years ago
Created attachment 8734019 [details]
64-bit nightly windows 7

Here is the latest 64-bit windows 7 nightly. This would explain why I suddenly crashed earlier today on my 32-bit beta, it chews through 3GB of ram in less than 20 seconds on my windows 7 computer
Hi Kyle,

Does this issue occurres on other browsers as well when visiting forecast.io?

Thanks,
Paul.
Flags: needinfo?(mrkmg90)
Marking this as Resolved: Incomplete due to the lack of response from the reporter.
If anyone can still reproduce it on latest versions, feel free to reopen the issue and provide more information.
Flags: needinfo?(mrkmg90)
Flags: needinfo?(gwmali01)

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.